Bug 5284 - Piping in the sendmail aliases file no longer works
Summary: Piping in the sendmail aliases file no longer works
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: sendmail   
(Show other bugs)
Version: 6.0
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Cristian Gafton
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 1999-09-21 21:10 UTC by hughett
Modified: 2008-05-01 15:37 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-02-16 13:57:49 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description hughett 1999-09-21 21:10:23 UTC
We have some sendmail aliases configured to distribute
meeting minutes to a mailing list AND copied to an
archive file for later reference, using the following
lines in /etc/aliases:

computer:       :include:/etc/mail.lists/computer
computer-minutes:  computer, "|/usr/local/sbin/minutes \
/home/minutes/computer"

The minutes script is as follows:

#! /bin/sh
#
# minutes - add mail message to a minutes directory
#
# This script reads the standard input and appends it to a
file in
# the directory specified by the first command line argument
and the
# current year..  The file
# name is always the current year, month, and day in the
form YYYYMMDD
# and will be created if it does not already exist.  The
purpose of this
# script is to facilitate the automatic archiving of
committee minutes
# sent to a mailing list.

year=`date +%Y`
date=`date +%Y-%m-%d`
fname=$1/$year/$date
if [ ! -d $1/$year ] ; then
   mkdir $1/$year
fi
touch $fname
cat >>$fname

and has permissions

-rwxrwxr--   1 root     mail          607 May 15 15:46
/usr/local/sbin/minutes

If we send an email to computer-minutes, it bounces back
with error messages:


   ----- The following addresses had permanent fatal errors
-----
"|/usr/local/sbin/minutes /home/minutes/computer"
    (expanded from:
<computer-minutes@bblmail.psycha.upenn.edu>)

   ----- Transcript of session follows -----
sh: minutes not available for sendmail programs
554 "|/usr/local/sbin/minutes /home/minutes/computer"...
Service unavailable
procmail: Lock failure on "/var/spool/mail/gao.lock"
procmail: Lock failure on "/var/spool/mail/gur.lock"
procmail: Lock failure on "/var/spool/mail/macy.lock"
procmail: Lock failure on "/var/spool/mail/brensing.lock"

gao, gur, macy, brensing, and hughett are the names given
in the computer mailing list.  Mailing to plain computer
(without the minutes archiving) works without any problems
and produces no complaints about lock files.  This same
setup worked fine under RH 5.1.

Paul Hughett

Comment 1 Bernhard Rosenkraenzer 2000-02-16 13:57:59 UTC
It's not a bug, it's a feature: The pipes were often abused to launch malicious
programs.
Newer versions of sendmail permit you to launch programs only when they're
located in the /etc/smrsh directory, so the admin can make sure only approved
programs can be launched.


Note You need to log in before you can comment on or make changes to this bug.