Bug 528423 - KeyError: <yuminstall.AnacondaYumRepo object at 0xb42375ac>
KeyError: <yuminstall.AnacondaYumRepo object at 0xb42375ac>
Status: CLOSED DUPLICATE of bug 505189
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
rawhide
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
anaconda_trace_hash:b353940c511c4bdcf...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-10-12 01:53 EDT by He Rui
Modified: 2009-10-12 09:32 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-10-12 09:32:43 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
Attached traceback automatically from anaconda. (839.12 KB, text/plain)
2009-10-12 01:53 EDT, He Rui
no flags Details

  None (edit)
Description He Rui 2009-10-12 01:53:47 EDT
The following was filed automatically by anaconda:
anaconda 12.36 exception report
Traceback (most recent call first):
  File "/usr/lib/python2.6/site-packages/yum/sqlitesack.py", line 234, in _sql_MD
    cache = getattr(self.sack, MD + 'db')[self.repo]
  File "/usr/lib/python2.6/site-packages/yum/sqlitesack.py", line 45, in newFunc
    return func(*args, **kwargs)
  File "/usr/lib/python2.6/site-packages/yum/sqlitesack.py", line 368, in returnPrco
    cur = self._sql_MD('primary', sql, (self.pkgKey,))
  File "/usr/lib/python2.6/site-packages/yum/packages.py", line 458, in returnPrcoNames
    lists = self.returnPrco(prcotype)
  File "/usr/lib/python2.6/site-packages/yum/packages.py", line 480, in <lambda>
    provides_names = property(fget=lambda self: self.returnPrcoNames('provides'))
  File "/usr/lib/python2.6/site-packages/yum/depsolve.py", line 196, in allowedMultipleInstalls
    provides = po.provides_names
  File "/usr/lib/python2.6/site-packages/yum/__init__.py", line 2849, in install
    if not self.allowedMultipleInstalls(po):
  File "/usr/lib/python2.6/site-packages/yum/transactioninfo.py", line 206, in add
    for condtxmbr in self.install_method(po=pkg):
  File "/usr/lib/python2.6/site-packages/yum/transactioninfo.py", line 544, in add
    TransactionData.add(self, txmember)
  File "/usr/lib/anaconda/sortedtransaction.py", line 71, in add
    SortableTransactionData.add(self, txmember)
  File "/usr/lib/python2.6/site-packages/yum/transactioninfo.py", line 341, in addInstall
    self.add(txmbr)
  File "/usr/lib/python2.6/site-packages/yum/depsolve.py", line 585, in _requiringFromTransaction
    txmbr = self.tsInfo.addInstall(best)
  File "/usr/lib/python2.6/site-packages/yum/depsolve.py", line 283, in _processReq
    CheckDeps, missingdep = self._requiringFromTransaction(po, requirement, errormsgs)
  File "/usr/lib/python2.6/site-packages/yum/depsolve.py", line 802, in _resolveRequires
    (checkdep, missing, errormsgs) = self._processReq(po, dep)
  File "/usr/lib/python2.6/site-packages/yum/depsolve.py", line 709, in resolveDeps
    CheckDeps, checkinstalls, checkremoves, missing = self._resolveRequires(errors)
  File "/usr/lib/python2.6/site-packages/yum/__init__.py", line 794, in buildTransaction
    (rescode, restring) = self.resolveDeps()
  File "/usr/lib/anaconda/yuminstall.py", line 1320, in doPostSelection
    (code, msgs) = self.ayum.buildTransaction()
  File "/usr/lib/anaconda/backend.py", line 282, in doPostSelection
    return anaconda.backend.doPostSelection(anaconda)
  File "/usr/lib/anaconda/dispatch.py", line 200, in moveStep
    rc = stepFunc(self.anaconda)
  File "/usr/lib/anaconda/dispatch.py", line 123, in gotoNext
    self.moveStep()
  File "/usr/lib/anaconda/gui.py", line 1195, in nextClicked
    self.anaconda.dispatch.gotoNext()
KeyError: <yuminstall.AnacondaYumRepo object at 0xb42375ac>
Comment 1 He Rui 2009-10-12 01:53:57 EDT
Created attachment 364423 [details]
Attached traceback automatically from anaconda.
Comment 2 Chris Lumens 2009-10-12 09:32:43 EDT

*** This bug has been marked as a duplicate of bug 505189 ***

Note You need to log in before you can comment on or make changes to this bug.