Bug 528498 - mount.nfs has unnecessarily SUID bit set
mount.nfs has unnecessarily SUID bit set
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: nfs-utils (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Steve Dickson
Fedora Extras Quality Assurance
: Triaged
: 646447 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-10-12 10:14 EDT by Ulrich Drepper
Modified: 2011-10-04 11:51 EDT (History)
2 users (show)

See Also:
Fixed In Version: nfs-utils-1.2.5-2.fc17
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-10-04 11:51:09 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ulrich Drepper 2009-10-12 10:14:14 EDT
Description of problem:
mount.nfs is he only mount.XX program which has the SUID bit set.  Only mount needs it set.

Version-Release number of selected component (if applicable):
1.2.0-16

How reproducible:
always

Steps to Reproduce:
1.ls -l /sbin/mount.nfs
2.
3.
  
Actual results:
-rwsr-xr-x. 1 root root 96288 2009-09-09 05:09 /sbin/mount.nfs


Expected results:
-rwxr-xr-x. 1 root root 96288 2009-09-09 05:09 /sbin/mount.nfs


Additional info:
Comment 1 Bug Zapper 2009-11-16 08:33:04 EST
This bug appears to have been reported against 'rawhide' during the Fedora 12 development cycle.
Changing version to '12'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 2 Steve Dickson 2011-10-04 11:51:36 EDT
*** Bug 646447 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.