Bug 528535 - rpmdiff prints empty line when no change between packages
rpmdiff prints empty line when no change between packages
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: rpmlint (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Ville Skyttä
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-10-12 13:07 EDT by Kamil Páral
Modified: 2010-02-19 19:09 EST (History)
3 users (show)

See Also:
Fixed In Version: rpmlint-0.94-1.fc12
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-11-02 16:45:31 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Kamil Páral 2009-10-12 13:07:33 EDT
Description of problem:
When packages are not the same, rpmdiff prints differences, every difference on a single line. No line is empty.

When packages are the same (at least from rpmdiff's perspective), rpmdiff prints single empty line.

That's is not correct, in my opinion. It should not print anything in the second case. When there is some line printed, I expect something to be there.

As a matter of fact, my script, which I am building on top of rpmdiff, is crashing exactly because of this issue.

Version-Release number of selected component (if applicable):
rpmlint-0.91-1.fc12.noarch

How reproducible:
always

Steps to Reproduce:
1. $ rpmdiff package.rpm package.rpm
Comment 1 Ville Skyttä 2009-10-13 15:04:01 EDT
Fixed upstream, but I suggest making your script more robust against unexpected input.  http://rpmlint.zarb.org/cgi-bin/trac.cgi/changeset/1664
Comment 2 Ville Skyttä 2009-11-02 16:45:31 EST
Included in 0.92-1.
Comment 3 Fedora Update System 2010-01-25 18:28:42 EST
rpmlint-0.93-2.fc12 has been submitted as an update for Fedora 12.
http://admin.fedoraproject.org/updates/rpmlint-0.93-2.fc12
Comment 4 Fedora Update System 2010-01-31 18:23:03 EST
rpmlint-0.94-1.fc12 has been submitted as an update for Fedora 12.
http://admin.fedoraproject.org/updates/rpmlint-0.94-1.fc12
Comment 5 Fedora Update System 2010-02-19 19:09:31 EST
rpmlint-0.94-1.fc12 has been pushed to the Fedora 12 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.