Bug 528545 - Unable to use usb devices on 2.6.31
Unable to use usb devices on 2.6.31
Status: CLOSED DUPLICATE of bug 524808
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-10-12 14:05 EDT by José Matos
Modified: 2009-10-13 22:07 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-10-13 22:07:09 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
dmesg 2.6.31.1-56.fc12.x86_64 output (68.63 KB, text/plain)
2009-10-12 14:06 EDT, José Matos
no flags Details

  None (edit)
Description José Matos 2009-10-12 14:05:23 EDT
I have installed my laptop using the (F12) Alpha installer and then around September 25th I have update my laptop to the latest rawhide.

All the installed kernel other than the initial kernel-2.6.31-0.125.4.2.rc5.git2.fc12.x86_64 refuse to use usb devices (in my case the most used is an external mouse).

While in grub the mouse is connected as seen by the green light of the optical mouse, as soon as the kernel loads to mouse is turned off and any attempt to connect gets the same treatment.

I have attached the dmesg output of 2.6.31.1-56.fc12.x86_64
Comment 1 José Matos 2009-10-12 14:06:24 EDT
Created attachment 364501 [details]
dmesg 2.6.31.1-56.fc12.x86_64 output
Comment 2 Chuck Ebbert 2009-10-13 20:23:59 EDT
Your system BIOS is badly broken. Blame HP. Maybe there is an update available?

It should work if you boot with the kernel option "intel_iommu=off".
Comment 3 Chuck Ebbert 2009-10-13 22:07:09 EDT

*** This bug has been marked as a duplicate of bug 524808 ***

Note You need to log in before you can comment on or make changes to this bug.