Bugzilla (bugzilla.redhat.com) will be under maintenance for infrastructure upgrades and will not be available on July 31st between 12:30 AM - 05:30 AM UTC. We appreciate your understanding and patience. You can follow status.redhat.com for details.
Bug 528557 - paprefs should be rebuilt for new pulse audio.
Summary: paprefs should be rebuilt for new pulse audio.
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: paprefs
Version: rawhide
Hardware: All
OS: Linux
low
high
Target Milestone: ---
Assignee: Lennart Poettering
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 528830 529251 553856 557975 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2009-10-12 19:30 UTC by Michael S.
Modified: 2011-11-25 10:56 UTC (History)
15 users (show)

Fixed In Version: 0.9.9-5.fc12
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2010-01-27 01:09:55 UTC
Type: ---


Attachments (Terms of Use)

Description Michael S. 2009-10-12 19:30:33 UTC
Description of problem:
paprefs do not load modules as it seeks the wrong modules directory

Version-Release number of selected component (if applicable):
paprefs-0.9.9-2.fc12.i686

How reproducible:
each time

Steps to Reproduce:
1. run paprefs
2. try to install any missing plugins

  
Actual results:
paprefs try to use  /usr/lib/pulse-0.9.16/modules/module-zeroconf-discover.so

Expected results:
paprefs should use /usr/lib/pulse-0.9.19/modules/module-zeroconf-discover.so


So i guess paprefs just requires a simple rebuild.

Comment 1 Matthias Clasen 2009-10-14 02:30:30 UTC
*** Bug 528830 has been marked as a duplicate of this bug. ***

Comment 2 Lennart Poettering 2009-10-14 14:44:55 UTC
Rebuild and requested tag:

https://fedorahosted.org/rel-eng/ticket/2478

Comment 3 Lennart Poettering 2009-10-15 22:12:59 UTC
*** Bug 529251 has been marked as a duplicate of this bug. ***

Comment 4 Paul W. Frields 2009-10-15 23:22:05 UTC
That was super-fast, thanks Lennart!

Comment 5 Nicolas Chauvet (kwizart) 2009-11-17 21:45:20 UTC
This is the same problem but with :
Actual results:
paprefs try to use  /usr/lib/pulse-0.9.19/modules/module-zeroconf-discover.so

Expected results:
paprefs should use /usr/lib/pulse-0.9.20/modules/module-zeroconf-discover.so

This problem is meant to be fixed at the rpm level if cannot be fixed at the code level. If you need to rebuild paprefs for the next pulseaudio please try to avoid such misbehaviour with an accurate rpm Requires on the pulseaudio version of the modules.

Comment 6 Paul W. Frields 2009-11-18 14:07:50 UTC
I think the idea is that PulseAudio uses a non-distro-specific method (e.g. PackageKit) to satisfy a user's request for an uninstalled module, rather than an erroneous Requires.  Perhaps this is done with a DBus message that PK understands as a request for a capability?  I haven't looked at the code so I don't know for sure.

In any case, it should probably be part of the package maintenance routine to rebuild all these bits together (chained?).

Comment 7 Aniket 2009-11-30 18:53:45 UTC
This problem has surfaced again. paprefs is trying to find modules in /usr/lib64/pulse-0.9.19 while they are in pulse-0.9.21 directory. 

This prevents me from enabling some of the options in paprefs to allow network access etc. As a temporary workaround I have created symlinks , but we need a longterm solution.

Comment 8 Paolo Patruno 2009-12-27 10:44:17 UTC
This problem is on again.
Now, to solve, paprefs just requires a simple rebuild.
thanks

Comment 9 Mark Williamson 2010-01-03 03:23:04 UTC
I'm seeing this bug too.

I had a /usr/lib64/pulse-0.9.19 and a /usr/lib64/pulse-0.9.21, whereas my 32-bit system had only the latter.  I made a symlink pulse-0.9.19 -> pulse-0.9.21 (moving the old directory away on the 64-bit system) and that made paprefs believe that I had the correct modules installed.

If paprefs packages depend on a specific version of the pulseaudio packages then perhaps a stricter dependency or packaging them together could help to avoid such mismatches?  Anyhow, I'm happy to have a workaround for the moment (and of course, PA worked fine when I wasn't trying to configure the more advanced preferences paprefs offers).

Comment 10 Lennart Poettering 2010-01-11 17:00:21 UTC
*** Bug 553856 has been marked as a duplicate of this bug. ***

Comment 11 Lennart Poettering 2010-01-25 17:28:59 UTC
*** Bug 557975 has been marked as a duplicate of this bug. ***

Comment 12 Fedora Update System 2010-01-25 17:46:52 UTC
paprefs-0.9.9-5.fc12 has been submitted as an update for Fedora 12.
http://admin.fedoraproject.org/updates/paprefs-0.9.9-5.fc12

Comment 13 Fedora Update System 2010-01-27 01:09:49 UTC
paprefs-0.9.9-5.fc12 has been pushed to the Fedora 12 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 14 Bjoern Rasmussen 2010-01-30 19:25:44 UTC
Works fine now :-)  Thanks!!

Comment 15 Rudd-O DragonFear 2011-11-25 08:35:36 UTC
Bug again.  0.9.23 RPM, asking for 0.9.22 module-zeroconf-discover.  NOT FIXED.

Comment 16 Rudd-O DragonFear 2011-11-25 08:36:07 UTC
Please reopen this bug.

Comment 17 Julian Sikorski 2011-11-25 10:48:34 UTC
Please open a new one, this one is against rawhide.


Note You need to log in before you can comment on or make changes to this bug.