Bug 52859 - remove hack that disables "keep panel below other windows"
remove hack that disables "keep panel below other windows"
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: gnome-core (Show other bugs)
7.3
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Havoc Pennington
Aaron Brown
:
: 52738 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-08-29 23:18 EDT by Bill Nottingham
Modified: 2014-03-16 22:23 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-03-01 10:40:14 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Bill Nottingham 2001-08-29 23:18:02 EDT
Panel->Miscellaneous->Panel treatment

One option is: Keep panels below other windows.

Notably, this keeps it below the nautilus desktop. :)
Comment 1 Alexander Larsson 2001-08-30 10:29:09 EDT
That setting is sort of random. It places the panel in the "desktop layer",
meaning that nautilus and the panel is in the same layer. Then the window
manager randomly selects which window is at top.

The feature itself can be useful (polling around the office two people use it),
but maybe we should add a gruesome hack to make the panel stay over nautilus.
Otherwise it is hard to recover from this state.
Comment 2 Havoc Pennington 2001-08-30 11:20:49 EDT
A gruesome hack isn't needed; there is a window layer above the desktop and
below the normal windows. We can set the panel in that layer. So this is a 
one-char fix, like s/2/3/

There's some risk it will confuse the hell out of Sawfish. I'll 
test out the change and see if it looks safe.
Comment 3 Havoc Pennington 2001-08-30 11:42:15 EDT
Ouch, it turns out the panel is already setting the between-desktop-and-windows
hint,and nautilus sets the desktop hint. So this is a Sawfish issue.
Comment 4 Havoc Pennington 2001-09-04 16:31:24 EDT
*** Bug 52738 has been marked as a duplicate of this bug. ***
Comment 5 Havoc Pennington 2001-09-05 12:55:36 EDT
gruesome sawfish workaround added to gnome-core 1.4.0.4-37

need to remove the gnome-core hack when sawfish is fixed
Comment 6 Havoc Pennington 2002-03-05 14:31:39 EST
 Should be fixed in 1.4.0.4-43

Note You need to log in before you can comment on or make changes to this bug.