Bug 528590 - IA-32 EL's patch to fix nanosleep and fadvise bug
Summary: IA-32 EL's patch to fix nanosleep and fadvise bug
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: ia32el
Version: 5.5
Hardware: All
OS: Linux
high
high
Target Milestone: rc
: 5.5
Assignee: Petr Machata
QA Contact: BaseOS QE
URL:
Whiteboard:
: 528592 528595 (view as bug list)
Depends On:
Blocks: 529716 533941
TreeView+ depends on / blocked
 
Reported: 2009-10-13 01:42 UTC by Xiaolan
Modified: 2018-10-27 11:43 UTC (History)
14 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2010-03-30 08:27:09 UTC
Target Upstream Version:


Attachments (Terms of Use)
patch for ia-32el v7 (4.28 KB, application/octet-stream)
2009-10-13 01:44 UTC, Xiaolan
no flags Details
patch to fix fadvise64_64 (3.91 KB, application/octet-stream)
2009-12-11 01:46 UTC, Xiaolan
no flags Details
reproducer for nanosleep (2.67 KB, text/x-csrc)
2010-01-25 00:59 UTC, Moritoshi Oshiro
no flags Details


Links
System ID Private Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2010:0250 0 normal SHIPPED_LIVE ia32el bug fix update 2010-03-29 12:44:49 UTC

Description Xiaolan 2009-10-13 01:42:53 UTC
syscall clock_nanosleep and posix_fadvise works wrongly. 

These two bugs were reported by Fujitsu.


The patch was attached

Comment 1 Xiaolan 2009-10-13 01:44:11 UTC
Created attachment 364537 [details]
patch for ia-32el v7

Comment 4 Petr Machata 2009-12-01 14:54:11 UTC
*** Bug 528595 has been marked as a duplicate of this bug. ***

Comment 5 Petr Machata 2009-12-01 14:54:27 UTC
*** Bug 528592 has been marked as a duplicate of this bug. ***

Comment 7 Issue Tracker 2009-12-09 04:35:43 UTC
Event posted on 12-09-2009 01:35pm JST by moshiro@redhat.com

Following is from Fujitsu regarding the proposed patch:

---
> Intel reports that they have fixed the clock_nanosleep() and fadvise64()
syscall bugs. They created a new Bugzilla entry to track the patch:
>
> https://bugzilla.redhat.com/show_bug.cgi?id=528590

We checked the patch attached at Bug #528590.
It fixes fadvise64() but does _not_ fix fadvise64_64().
We are afraid Intel forgot fadvise64_64().
---

Could you please verify it and reply to this comment?

Best Regards,
M Oshiro


This event sent from IssueTracker by moshiro@redhat.com 
 issue 346929

Comment 8 Xiaolan 2009-12-11 01:46:45 UTC
Created attachment 377642 [details]
patch to fix fadvise64_64

Comment 9 Xiaolan 2009-12-11 01:48:47 UTC
The patch to fix fadvise64_64 was uploaded. Sorry for the inconvenience.

Regards,
Xiaolan

Comment 11 Michal Nowak 2010-01-22 10:20:05 UTC
Oshiro-san,

can you attach testcases for this two bugs so we can test fixes in house, please? From https://bugzilla.redhat.com/show_bug.cgi?id=528595 it seems that one of the test cases (fadvise64_64()) might sit in IssueTracker.

Comment 12 Petr Machata 2010-01-22 11:10:42 UTC
Michal, I attached the fadvise reproducer to the bug 528595.  I'm leaving the needinfo in, since we still need the test case for nanosleep.

Comment 13 Moritoshi Oshiro 2010-01-25 00:59:54 UTC
Created attachment 386518 [details]
reproducer for nanosleep

This is a reproducer for nanosleep.

Comment 16 errata-xmlrpc 2010-03-30 08:27:09 UTC
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2010-0250.html


Note You need to log in before you can comment on or make changes to this bug.