This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 528639 - internal compiler error: in loc_cmp, at var-tracking.c:2433
internal compiler error: in loc_cmp, at var-tracking.c:2433
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: gcc (Show other bugs)
rawhide
arm9 Linux
high Severity medium
: ---
: ---
Assigned To: Jakub Jelinek
Fedora Extras Quality Assurance
: Reopened
Depends On:
Blocks: ARMTracker
  Show dependency treegraph
 
Reported: 2009-10-13 03:33 EDT by Kedar Sovani
Modified: 2009-11-09 12:37 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-11-09 12:37:37 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
auto-generated pre-compiled sources (226.67 KB, application/octet-stream)
2009-10-13 03:34 EDT, Kedar Sovani
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
GNU Compiler Collection 41679 None None None Never

  None (edit)
Description Kedar Sovani 2009-10-13 03:33:32 EDT
Host/Build/Target Triple: armv5tel-redhat-linux-gnueabi

with gcc version: gcc-4.4.1-21

Complete build logs:
http://arm.koji.fedoraproject.org/koji/getfile?taskID=73218&name=build.log

Initially I thought this to be the same as
http://gcc.gnu.org/bugzilla/show_bug.cgi?id=41252. But the gcc sources already
had the patch indicated in that bug
(http://gcc.gnu.org/viewcvs?root=gcc&view=rev&rev=151437)
Comment 1 Kedar Sovani 2009-10-13 03:34:22 EDT
Created attachment 364554 [details]
auto-generated pre-compiled sources

auto-generated pre-compiled sources
Comment 2 Jakub Jelinek 2009-10-19 06:44:55 EDT
Can't reproduce this with redhat/gcc-4_4-branch and a cross compiler.  So, please try gcc-4.4.2-4.fc12.
Comment 3 Kedar Sovani 2009-10-21 06:11:12 EDT
Re-opening this bug. It is still seen with gcc-4.4.2-5.fc12

Failure build log:
http://arm.koji.fedoraproject.org/koji/getfile?taskID=73937&name=build.log&offset=-2000

Would it be rather better to reopen this bug:
http://gcc.gnu.org/bugzilla/show_bug.cgi?id=41679

Although the bug is in the Fedora branch, some gcc-arm folks might at least *suggest* some fixes/tweaks etc. over there
Comment 4 Jakub Jelinek 2009-11-09 11:35:27 EST
Sorry, still can't reproduce, so there is hardly anything I can do about it.

You could try to build just first stage of gcc on arm (configure with --disable-bootstrap in addition to the options gcc.spec passes to configure), see if even the first stage reproduces it.  If not, this might be miscompilation of gcc itself.
Comment 5 Jakub Jelinek 2009-11-09 11:47:25 EST
Actually, after hand editting auto-host.h quite a bit to more match the native one and what I guess arm gas provides I've managed to reproduce it.  Looking into it.
Comment 6 Jakub Jelinek 2009-11-09 12:11:29 EST
Smaller testcase:

/* { dg-do compile } */
/* { dg-options "-march=armv5te -g -O2" } */

extern int a;
extern char b;
extern int foo (void);

void
test (void)
{
  int c;
  b = foo () ? '~' : '\0';
  while ((c = foo ()))
    if (c == '7')
      a = 0;
}

Note You need to log in before you can comment on or make changes to this bug.