Bugzilla (bugzilla.redhat.com) will be under maintenance for infrastructure upgrades and will not be available on July 31st between 12:30 AM - 05:30 AM UTC. We appreciate your understanding and patience. You can follow status.redhat.com for details.
Bug 528640 - mod_proxy_ajp fails with large file uploads
Summary: mod_proxy_ajp fails with large file uploads
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: httpd
Version: 5.4
Hardware: All
OS: Linux
low
medium
Target Milestone: rc
: ---
Assignee: Joe Orton
QA Contact: BaseOS QE
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2009-10-13 07:40 UTC by Tobias Barth
Modified: 2010-03-30 08:28 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2010-03-30 08:28:42 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Apache Bugzilla 45911 0 None None None Never
Red Hat Product Errata RHEA-2010:0252 0 normal SHIPPED_LIVE httpd bug fix and enhancement update 2012-05-17 17:57:35 UTC

Description Tobias Barth 2009-10-13 07:40:38 UTC
Description of problem:
we are working with RHEL 5 in a customer's project. They have the Apache 2.2.3 package "httpd-2.2.3-31.el5" with mod_proxy_apr and tomcat 6.0.20 installed on RHEL x86_64 web servers. We now encountered a file upload problem similar to the following one:
 
https://issues.apache.org/bugzilla/show_bug.cgi?id=45911
 
At the end of the bug description it is mentioned that the bug has been fixed for all apache versions > 2.2.9 - so we tried that out and the issue was gone with Apache 2.2.14. I think that problem is not platform-dependent since we could also reproduce it on windows systems.
 

Version-Release number of selected component (if applicable):
httpd-2.2.3-31.el5


How reproducible:
use a servlet in tomcat 6.0.20, httpd and mod_proxy_apr and upload a .zip-file with 3 or 4 megabytes. The .zip file will be unreadable by the servlet because it is either bigger or smaller than the original file.

Steps to Reproduce:
1. Install tomcat 6.0.20, httpd-2.2.3-31.el5 with mod_proxy_apr
2. Handle file uploads (either with the com.oreilly classes or the apache file upload library)
3. Upload a large .zip file and compare the uploaded file with the original
4. Install httpd 2.2.14 with its mod_proxy_apr module and do the test again.

Comment 1 Joe Orton 2009-10-13 09:58:06 UTC
Thanks for the report.  We can backport that patch.

Comment 5 errata-xmlrpc 2010-03-30 08:28:42 UTC
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2010-0252.html


Note You need to log in before you can comment on or make changes to this bug.