Bug 528662 - "invalid symbolic color" when starting GTK apps
"invalid symbolic color" when starting GTK apps
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: kdebase-workspace (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Ngo Than
Fedora Extras Quality Assurance
: Triaged
Depends On:
Blocks: F12Blocker-kde
  Show dependency treegraph
 
Reported: 2009-10-13 04:56 EDT by Mary Ellen Foster
Modified: 2009-10-23 12:58 EDT (History)
12 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-10-23 12:58:57 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
My ~/.kde/share/config/gtkrc-2.0 (written out by KDE 4.3.1 on F10) (1.57 KB, text/plain)
2009-10-22 01:16 EDT, Kevin Kofler
no flags Details

  None (edit)
Description Mary Ellen Foster 2009-10-13 04:56:40 EDT
Description of problem:
Every time I start a GTK app, I get the following two lines printed out:
/usr/share/themes/Clearlooks/gtk-2.0/gtkrc:51: Invalid symbolic color 'bg_color'
/usr/share/themes/Clearlooks/gtk-2.0/gtkrc:51: error: invalid identifier 'bg_color', expected valid identifier

I've specifically noticed this with firefox and gvim, but I assume it'll happen with any other GTK apps too.


Version-Release number of selected component (if applicable):
gtk2-engines-2.18.4-1.fc12.x86_64

How reproducible:
Every time

Steps to Reproduce:
1. Start gvim or firefox
  
Additional info:
I'm using KDE as a desktop environment, but that may not be relevant.
Comment 1 Rex Dieter 2009-10-21 16:17:54 EDT
I can confirm this for many of the themes here that contain similar @bg_color constructs in gtkrc.

It may or may not be relevant, but gtk apps seem to be not themed properly when this error appears (using some fairly non-pretty theme).

Any ideas what's going on?
Comment 2 Matthias Clasen 2009-10-21 18:11:49 EDT
The non-pretty theme is a side-effect of the rc file parsing erroring out - it falls back to the builtin (Raleigh) theme.
Comment 3 Rex Dieter 2009-10-21 19:08:45 EDT
OK, so suggestions on how to resolve this?  I'm at a loss.
Comment 4 Matthias Clasen 2009-10-21 19:47:51 EDT
I need to learn a way to reproduce this. 
Is an xsettings-manager running when this is happening ? 
Is it maybe exporting a value forGtk/ColorScheme that does not contain a value for bg_color ?
Comment 5 Kevin Kofler 2009-10-21 20:42:02 EDT
AFAIK, we run xsettings-kde by default in KDE, so it might be worth having a look there.
Comment 6 Rex Dieter 2009-10-21 21:05:33 EDT
I thought about that.

I previously reproduced it with and without xsettings-kde running.  Even tried running gnome-settings-daemon as well.

I'll try again with a fresh user.
Comment 7 Rex Dieter 2009-10-22 00:28:31 EDT
OK, narrowed it down to kde's systemsettings->appearance->colors option
"Apply colors to non-KDE4 applications"
when that is enabled, this issue occurs.

Looks like our(kde's) problem to solve.
Comment 8 Matthias Clasen 2009-10-22 01:08:38 EDT
Still somewhat my problem, too. We ought to be more tolerant against these kinds of things here. If you could tell me what value your xsettings manager is exporting for Gtk/ColorScheme, that would be great.
Comment 9 Kevin Kofler 2009-10-22 01:12:23 EDT
It's not xsettings-kde which is apparently faulty, but the gtkrc files written out by kdebase-workspace.
Comment 10 Kevin Kofler 2009-10-22 01:16:03 EDT
Created attachment 365649 [details]
My ~/.kde/share/config/gtkrc-2.0 (written out by KDE 4.3.1 on F10)

So, this is what KDE 4.3.x writes out (the format should be the same in all 4.3.x versions, only the actual values of the colors depend on the user's color scheme). I guess the floating-point colors are what the F12 GTK+ is not liking?
Comment 11 Matthias Clasen 2009-10-22 08:28:56 EDT
Those floats are fine, according to http://library.gnome.org/devel/gtk/stable/gtk-Resource-Files.html#color-format
Comment 12 Ngo Than 2009-10-22 10:24:12 EDT
i try with the steps in comment #7, cannot reproduce this issue with a fresh user.
Comment 13 Matthias Clasen 2009-10-22 10:28:14 EDT
I can, with the gtkrc file that Kevin posted.
Comment 14 Matthias Clasen 2009-10-22 22:29:01 EDT
Fixed in gtk2-2.18.3-9.fc12
Comment 15 Adam Williamson 2009-10-23 12:58:57 EDT
Matthias is confident of the fix and Rex tested the tag request, so closing this as we're fairly sure it's good. Mary, please re-open if you still have problems after updating to that version of gtk2 or later.

-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers

Note You need to log in before you can comment on or make changes to this bug.