Bug 528677 - Add again iok support in ibus-m17n
Summary: Add again iok support in ibus-m17n
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: ibus-m17n
Version: rawhide
Hardware: All
OS: Linux
high
medium
Target Milestone: ---
Assignee: Peng Huang
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2009-10-13 10:43 UTC by Parag Nemade
Modified: 2009-10-23 05:53 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2009-10-23 05:53:09 UTC
Type: ---


Attachments (Terms of Use)

Description Parag Nemade 2009-10-13 10:43:08 UTC
Description of problem:
Last build of ibus-m17n removed iok support. Please apply patch in Fedora package cvs of iok support to ibus-m17n source code.

Version-Release number of selected component (if applicable):
ibus-m17n-1.2.0.20090617-2.fc12

How reproducible:
always

Steps to Reproduce:
1.select any indic inscript input engine.
2. check for iok icon on ibus panel.
3.
  
Actual results:
There is no iok icon on ibus panel.

Expected results:
There should be iok icon to support iok application.

Additional info:

Comment 1 Parag Nemade 2009-10-13 10:45:00 UTC
Please add new build to Fedora 12 Beta.

Comment 2 Peng Huang 2009-10-14 02:17:09 UTC
It is because of the patch will cause build failed. So please update the patch.

Comment 3 Parag Nemade 2009-10-14 03:24:05 UTC
Bug should have been opened already for updating patch.
Is there any way by which you can accept iok patch in upstream?
If not can we add new package for this functionality to Fedora?

Comment 4 Peng Huang 2009-10-14 03:36:22 UTC
How about other Linux distributions? Do they have iok?
If you can make the iok feature in ibus-m17n configurable (like ./configure --enable-iok), I will merge it.

Comment 5 Parag Nemade 2009-10-14 04:59:44 UTC
I have not checked iok in other Linux distribution. I will check for iok feature in ibus-m17n.

Thanks. I will work on this after beta release.

Comment 6 Fedora Update System 2009-10-14 07:52:41 UTC
ibus-m17n-1.2.0.20090617-4.fc12 has been submitted as an update for Fedora 12.
http://admin.fedoraproject.org/updates/ibus-m17n-1.2.0.20090617-4.fc12

Comment 7 Peng Huang 2009-10-14 07:54:40 UTC
Fixed in ibus-m17n-1.2.0.20090617-4.fc12

Comment 9 Jens Petersen 2009-10-15 07:52:35 UTC
I tested it on rawhide and looks fine to me.

Comment 10 Jens Petersen 2009-10-15 08:08:59 UTC
Actually there is a problem (not sure if it is a regression)
but if I switch to another IME and then back to the Indic one
then the iok button is gone.

Comment 12 A S Alam 2009-10-23 03:06:20 UTC
I have not seen iok icon after updating with following rpm
ibus-m17n-1.2.0.20090617-4.fc12.x86_64 

fresh install also Missing it

Comment 13 Peng Huang 2009-10-23 03:34:39 UTC
Which keymap did you test? I think ibus-m17n only shows the iok icon when you are using some in-script keymap.

Comment 14 A S Alam 2009-10-23 05:00:38 UTC
oh, sorry, I tested two languages and both has no in-script default.
Let me update machine again with incript and will update soon.

Thanks

Comment 15 A S Alam 2009-10-23 05:53:09 UTC
it is working as iok available with Inscript only.

Closing bug


Note You need to log in before you can comment on or make changes to this bug.