Bug 528687 - Allow febootstrap-run to be called by root
Summary: Allow febootstrap-run to be called by root
Status: CLOSED UPSTREAM
Alias: None
Product: Fedora
Classification: Fedora
Component: febootstrap (Show other bugs)
(Show other bugs)
Version: rawhide
Hardware: All Linux
low
medium
Target Milestone: ---
Assignee: Richard W.M. Jones
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2009-10-13 11:38 UTC by Alexey Torkhov
Modified: 2009-10-13 13:48 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-10-13 13:48:35 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
patch (736 bytes, patch)
2009-10-13 11:38 UTC, Alexey Torkhov
no flags Details | Diff

Description Alexey Torkhov 2009-10-13 11:38:18 UTC
Description of problem:
If febootstrap-run called by root on dir that was created by febootstrap, it shows an error: "febootstrap-run: ...: not a root filesystem"

Attached patch, or similar would resolve the problem.

Version-Release number of selected component (if applicable):
febootstrap-2.4-1.fc12.noarch

Comment 1 Alexey Torkhov 2009-10-13 11:38:48 UTC
Created attachment 364575 [details]
patch

Comment 2 Alexey Torkhov 2009-10-13 11:59:14 UTC
There are bug 525778, but my patch is contains better patch as it disables fakeroot run and allows to do 32-on-64 install (with setarch).

Which is not possible without root run according to man page.

Comment 3 Richard W.M. Jones 2009-10-13 12:53:53 UTC
Interesting if you could document how to do 32-on-64
installs somewhere.

I pushed the patch here:

http://git.et.redhat.com/?p=febootstrap.git;a=commit;h=e0948419331d56c8f95fdeba2bca12ed5b5f1270

Any comments on bug 528685?

Comment 4 Richard W.M. Jones 2009-10-13 12:54:20 UTC
(In reply to comment #3)
> Any comments on bug ------?  

I mean, bug 528577.

Comment 5 Alexey Torkhov 2009-10-13 13:22:12 UTC
(In reply to comment #3)
> Interesting if you could document how to do 32-on-64
> installs somewhere.

Command like this works for me from root:
LANG=C i386 febootstrap fedora-11 fedora-test -u updates-released-f11 -i bash

From user or without LANG=C it fails with various errors.

Comment 6 Richard W.M. Jones 2009-10-13 13:48:35 UTC
OK this is upstream, closing now.


Note You need to log in before you can comment on or make changes to this bug.