Bug 528688 - netdisco fails to install properly on x86_64 architecture
Summary: netdisco fails to install properly on x86_64 architecture
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: netdisco
Version: 11
Hardware: x86_64
OS: Linux
low
medium
Target Milestone: ---
Assignee: Walter Gould
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2009-10-13 11:47 UTC by Chuck Murnane
Modified: 2009-12-01 18:27 UTC (History)
1 user (show)

Fixed In Version: 1.0-2.el5
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2009-11-27 21:52:01 UTC


Attachments (Terms of Use)

Description Chuck Murnane 2009-10-13 11:47:41 UTC
Description of problem:
I run the x86_64 version of httpd and mod_perl. The /usr/sbin/netdisco_config
script modifies the netdisco file /etc/httpd/conf.d/netdisco_apache.conf so it
contains a reference to /usr/lib/httpd/modules/mod_perl.so, a file provided by
the mod_perl package. The x86_64 version, however, provides
/usr/lib64/httpd/modules/mod_perl.so, so I had to edit the
/etc/httpd/conf.d/netdisco_apache.conf file manually to provide that. I don't
have access to my 64 bit system right now, but looking at the netdisco_config
script, I don't think that it handles this case. As I recall, there were two
references to /usr/lib/httpd that had to change to /usr/lib64/httpd in that
netdisco_apache.conf file.  


Version-Release number of selected component (if applicable):
netdisco-0.95-4.fc11.noarch
httpd-2.2.13-1.fc11.x86_64
mod_perl-2.0.4-8.x86_64

How reproducible:
Happened on two different systems. Since I don't see that the 64-bit case is handled in the netdisco_config script, I believe it will always happen this way.

Steps to Reproduce:
1.yum install netdisco
2.
3.
  
Actual results:
/etc/httpd/conf.d/netdisco_apache.conf has references to /usr/lib/httpd

Expected results:
references should be to /usr/lib64/httpd

Additional info:

Comment 1 Fedora Update System 2009-11-09 23:25:53 UTC
netdisco-1.0-2.fc12 has been submitted as an update for Fedora 12.
http://admin.fedoraproject.org/updates/netdisco-1.0-2.fc12

Comment 2 Fedora Update System 2009-11-09 23:27:09 UTC
netdisco-1.0-2.fc11 has been submitted as an update for Fedora 11.
http://admin.fedoraproject.org/updates/netdisco-1.0-2.fc11

Comment 3 Fedora Update System 2009-11-09 23:28:37 UTC
netdisco-1.0-2.el5 has been submitted as an update for Fedora EPEL 5.
http://admin.fedoraproject.org/updates/netdisco-1.0-2.el5

Comment 4 Fedora Update System 2009-11-10 03:22:53 UTC
netdisco-1.0-2.el5 has been pushed to the Fedora EPEL 5 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update netdisco'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/EL-5/FEDORA-EPEL-2009-0828

Comment 5 Fedora Update System 2009-11-11 14:56:48 UTC
netdisco-1.0-2.fc11 has been pushed to the Fedora 11 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update netdisco'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F11/FEDORA-2009-11323

Comment 6 Fedora Update System 2009-11-11 15:05:19 UTC
netdisco-1.0-2.fc12 has been pushed to the Fedora 12 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update netdisco'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F12/FEDORA-2009-11383

Comment 7 Fedora Update System 2009-11-27 21:51:52 UTC
netdisco-1.0-2.fc12 has been pushed to the Fedora 12 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 8 Fedora Update System 2009-11-27 21:57:53 UTC
netdisco-1.0-2.fc11 has been pushed to the Fedora 11 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 9 Fedora Update System 2009-12-01 18:27:22 UTC
netdisco-1.0-2.el5 has been pushed to the Fedora EPEL 5 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.