Bugzilla (bugzilla.redhat.com) will be under maintenance for infrastructure upgrades and will not be available on July 31st between 12:30 AM - 05:30 AM UTC. We appreciate your understanding and patience. You can follow status.redhat.com for details.
Bug 528694 - copy/paste from jedit to thunderbird makes it crash with quadro videocards
Summary: copy/paste from jedit to thunderbird makes it crash with quadro videocards
Keywords:
Status: CLOSED DUPLICATE of bug 501685
Alias: None
Product: Fedora
Classification: Fedora
Component: thunderbird
Version: 11
Hardware: i386
OS: Linux
low
medium
Target Milestone: ---
Assignee: Gecko Maintainer
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2009-10-13 12:03 UTC by oll
Modified: 2018-04-11 07:07 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2009-10-16 11:07:34 UTC
Type: ---


Attachments (Terms of Use)
trace from gdb (28.96 KB, text/plain)
2009-10-16 08:37 UTC, oll
no flags Details

Description oll 2009-10-13 12:03:15 UTC
Description of problem:
With the latest patched FC11 (thunderbird 3.0beta4), a copy/paste from jedit to a new message in thunderbird make it crash

Version-Release number of selected component (if applicable):
Sorry, I didn't know where to fill this bug since I couldn't find if it's related to thunderbird and/or java and/or Xorg

How reproducible:
Have a Dell Precision 390 (Nvidia Quadro driver)
Download jedit and run it with "java -jar  installpath/jedit.jar"


Steps to Reproduce:
1. 
write Hello in jedit
2.
copy the string with ctrl+c 
3.
open a new message on thunderbird
4. 
paste with ctrl+v
  
Actual results:
thunderbird crashes, and even worse, go on crashing until you close jedit.

Expected results:
paste into thunderbird


Additional info:
I tried with different versions of java : the one by default from Fedora and the latest jre from Sun. It always crash.
I tried with nouveau, vesa and akmod-nvidia driver : it goes on crashing.
I tried on another Precision 390 : same crash 
It also crashes when I use the middle mouse button.
It doesn't crash if I choose "paste without formatting"

I tried with several other Dell stations (without quadro videocard) : It didn't crash.

I don't know how to do further investigations since I have no errors in Xorg logfile but feel free to ask me to do further testings since it's a blocking bug for my users.

Comment 1 Matěj Cepl 2009-10-14 12:40:35 UTC
OK, let's try to find out what actually is going on:

First of all, could we get output of the command

	rpm -qa *xulrun* *firefox* *mozilla* *flash* *plugin*

Please also install firefox-debuginfo (debuginfo-install is from
yum-utils package).

	debuginfo-install firefox

Then run firefox with a parameter -g. That will start firefox running inside of gdb debugger. Then use command run and do whatever you did to make firefox crash. When it happens, you should go back to the gdb and run

	(gdb) thread apply all backtrace

This produces usually many screens of the text. Copy all of them into a text editor and attach the file to the bug as an uncompressed attachment.

We will review this issue again once you've had a chance to attach this information.

Thanks in advance.

Comment 2 oll 2009-10-16 08:37:49 UTC
Created attachment 365026 [details]
trace from gdb

Comment 3 oll 2009-10-16 08:41:25 UTC
Thank you !

As you can see in the attached file, it crashes after complaning of a "missing" strcmp.S file.
But I'm not expert enough to know if it's something missing for thunderbird or for gdb.

Below are the versions used (there was a fresh upgrade from thunderbird this morning, but this bug remains)

[root@mercantour ~]# rpm -qa *xulrun* *thunderbird* *mozilla* *flash* *plugin*
plymouth-plugin-two-step-0.7.0-0.2009.05.15.1.fc11.i586
gstreamer-plugins-bad-0.10.13-7.fc11.i586
nspluginwrapper-1.3.0-6.fc11.i586
yum-plugin-downloadonly-1.1.23-1.fc11.noarch
gstreamer-plugins-schroedinger-1.0.7-1.fc11.i586
thunderbird-debuginfo-3.0-2.8.b4.fc11.i586
alsa-plugins-pulseaudio-1.0.21-2.fc11.i586
gstreamer-plugins-good-0.10.15-4.fc11.i586
nspluginwrapper-debuginfo-1.3.0-6.fc11.i586
PackageKit-gstreamer-plugin-0.4.9-1.fc11.i586
gstreamer-plugins-bad-extras-0.10.13-7.fc11.i586
gstreamer-plugins-ugly-0.10.12-2.fc11.i586
flash-plugin-10.0.32.18-release.i386
gdm-plugin-fingerprint-2.26.1-13.fc11.i586
xulrunner-debuginfo-1.9.1.3-1.fc11.i586
setroubleshoot-plugins-2.0.18-5.fc11.noarch
java-1.6.0-openjdk-plugin-1.6.0.0-29.b16.fc11.i586
gnome-do-plugins-thunderbird-0.8.1-6.fc11.i586
totem-mozplugin-2.26.3-5.fc11.i586
xulrunner-1.9.1.3-1.fc11.i586
gnome-do-plugins-0.8.1-6.fc11.i586
beagle-thunderbird-0.3.9-9.fc11.i586
mozilla-filesystem-1.9-4.fc11.i586
anaconda-yum-plugins-1.0-4.fc11.noarch
gstreamer-plugins-flumpegdemux-0.10.15-6.fc11.i586
gstreamer-plugins-base-0.10.24-1.fc11.i586
plymouth-plugin-label-0.7.0-0.2009.05.15.1.fc11.i586
thunderbird-3.0-2.8.b4.fc11.i586
PackageKit-yum-plugin-0.4.9-1.fc11.i586

Comment 4 Matěj Cepl 2009-10-16 11:07:34 UTC

*** This bug has been marked as a duplicate of bug 501685 ***


Note You need to log in before you can comment on or make changes to this bug.