Bug 52870 - Want shared-core for kylix
Want shared-core for kylix
Status: CLOSED WONTFIX
Product: Red Hat Linux
Classification: Retired
Component: apache (Show other bugs)
7.1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Nalin Dahyabhai
David Lawrence
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-08-30 05:03 EDT by Need Real Name
Modified: 2007-04-18 12:36 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-08-30 05:03:38 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2001-08-30 05:03:35 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 5.5; Windows NT 5.0)

Description of problem:
It would be nice if --enable-rule=SHARED_CORE were included in the config 
ready for 7.2 users who use kylix, or kylix-generated apache modules that 
will be depoloyed on 7.2 machines (as its too late for 7.1 and 7.0)

--- apache.spec.orig    Fri Aug 17 14:28:36 2001
+++ apache.spec Fri Aug 17 14:13:25 2001
@@ -101,6 +101,7 @@
        --enable-module=all \
        --enable-shared=max \
        --enable-rule=EAPI \
+       --enable-rule=SHARED_CORE \
        --disable-rule=WANTHSREGEX \
        --enable-module=auth_dbm \
        --with-perl=%{__perl} \
@@ -246,6 +247,7 @@
 %dir %{_libdir}/apache
 %{_libdir}/apache/httpd.exp
 %{_libdir}/apache/*.so
+%{_libdir}/apache/*.ep

 %{_mandir}/man*/*
Comment 1 Joe Orton 2002-09-11 16:21:33 EDT
Shared core is no longer supported upstream in Apache 2.0; this change is too
fundamental to make for the 1.3 packages and I don't see a good justification -
why does Kylix require a shared core for Apache modules it creates?
Comment 2 Need Real Name 2002-09-12 03:35:56 EDT
I don't think the change is very fundamental at all, it's one line in the .spec 
file and doesn't affect how apache is stopped or started.

Kylix needs it because the apache modules it generates want to link against 
libhttp (or whatever it is).  Why they did it that way I don't know.

If as you say Apache 2.0 can't do that I guess the Kylix folk will rethink 
anyway.

Note You need to log in before you can comment on or make changes to this bug.