Bug 528753 - References to "Xen domain" should be generic now that KVM is a possibility
Summary: References to "Xen domain" should be generic now that KVM is a possibility
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Satellite 5
Classification: Red Hat
Component: WebUI
Version: 530
Hardware: All
OS: Linux
low
low
Target Milestone: ---
Assignee: Justin Sherrill
QA Contact: Red Hat Satellite QA List
URL:
Whiteboard:
Depends On:
Blocks: 462714
TreeView+ depends on / blocked
 
Reported: 2009-10-13 15:24 UTC by Brian Likosar
Modified: 2011-03-07 18:32 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-03-07 18:32:17 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description Brian Likosar 2009-10-13 15:24:44 UTC
Description of problem:
When using Satellite to schedule the shutdown of a guest (Xen or KVM), the output on the Schedule tab says "Shuts down a Xen domain".

Version-Release number of selected component (if applicable):
5.3

How reproducible:
every time

Steps to Reproduce:
1.  Register a system as a virtualization platform (one that is running KVM and not Xen)
2.  Go to the Virtualization tab of that system.  Check the box of the KVM guest and choose shutdown systems, and hit the Apply Action button
3.  Click on the schedule tab at the top
  
Actual results:
see "Shuts down a Xen domain" for the task name

Expected results:
see "Shuts down a virtual guest" or some other generic phrasing

Additional info:

Comment 1 Clifford Perry 2009-10-26 18:46:11 UTC
This is a dupe, I just cannot find it right now. We have these strings in DB entries. 

See:
http://git.fedorahosted.org/git/?p=spacewalk.git;a=commitdiff;h=e763c895160aaf1999cb0cc21f5159d2351ea25f

This was too late for 530 to get the schema changes in. Most likely with next major version of Satellite release - either 5.4 or 6.0 Satellite (not sure version # yet). 

Cliff

Comment 2 Clifford Perry 2011-03-07 18:32:17 UTC
This is within Satellite 5.4 code base. 

Cliff


Note You need to log in before you can comment on or make changes to this bug.