Bug 5288 - can't start xkbcomp
can't start xkbcomp
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: XFree86 (Show other bugs)
6.0
alpha Linux
medium Severity medium
: ---
: ---
Assigned To: David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 1999-09-21 19:38 EDT by air_ogi
Modified: 2008-05-01 11:37 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 1999-09-27 16:45:21 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description air_ogi 1999-09-21 19:38:55 EDT
System:
Compaq AlphaServer DS10 with redhat everything install.

Problem:
Permission on /var/tmp (drwxr-xr-x) on alpha redhat systems
dont allow creating of temp/lock files by a non-root user.
This causes XKEYBOARD keymap compiler (xkbcomp) to exit
with write error and fall back to pre-keymap.

Solution:
Set permission to drwxrwxrt (sticky bit), as it is on i386
redhat.
Comment 1 air_ogi 1999-09-25 01:53:59 EDT
This bug was caused by kdenetwork-1.1.2-2.alpha.rpm installation. It
has nothing to do with X or filesystem rpm(s)
Comment 2 Preston Brown 1999-09-27 16:45:59 EDT
bug in kde packaging changed /var/tmp ownership, this was corrected.

Note You need to log in before you can comment on or make changes to this bug.