Bug 528818 - SELinux is preventing /usr/bin/ksudoku "execmem" access on <Unknown>.
Summary: SELinux is preventing /usr/bin/ksudoku "execmem" access on <Unknown>.
Keywords:
Status: CLOSED CANTFIX
Alias: None
Product: Fedora
Classification: Fedora
Component: setroubleshoot
Version: rawhide
Hardware: x86_64
OS: Linux
low
medium
Target Milestone: ---
Assignee: Daniel Walsh
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: setroubleshoot_trace_hash:2e29abaa633...
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2009-10-13 20:41 UTC by Martin Kho
Modified: 2009-10-14 16:56 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2009-10-14 12:38:14 UTC
Type: ---


Attachments (Terms of Use)

Description Martin Kho 2009-10-13 20:41:41 UTC
Summary:

SELinux is preventing /usr/bin/ksudoku "execmem" access on <Unknown>.

Detailed Description:

[SELinux is in permissive mode. This access was not denied.]

SELinux denied access requested by ksudoku. The current boolean settings do not
allow this access. If you have not setup ksudoku to require this access this may
signal an intrusion attempt. If you do intend this access you need to change the
booleans on this system to allow the access.

Allowing Access:

One of the following booleans is set incorrectly: allow_execstack, allow_execmem

Fix Command:

Choose one of the following to allow access:
Allow unconfined executables to make their stack executable. This should never,
ever be necessary. Probably indicates a badly coded executable, but could
indicate an attack. This executable should be reported in bugzilla")
# setsebool -P allow_execstack 1
Allow unconfined executables to map a memory region as both executable and
writable, this is dangerous and the executable should be reported in bugzilla")
# setsebool -P allow_execmem 1


Additional Information:

Source Context                unconfined_u:unconfined_r:unconfined_t:s0-s0:c0.c1
                              023
Target Context                unconfined_u:unconfined_r:unconfined_t:s0-s0:c0.c1
                              023
Target Objects                None [ process ]
Source                        amarok
Source Path                   /usr/bin/amarok
Port                          <Unknown>
Host                          (removed)
Source RPM Packages           kdegames-4.3.2-1.fc12
Target RPM Packages           
Policy RPM                    selinux-policy-3.6.32-24.fc12
Selinux Enabled               True
Policy Type                   targeted
MLS Enabled                   True
Enforcing Mode                Permissive
Plugin Name                   catchall_boolean
Host Name                     (removed)
Platform                      Linux (removed) 2.6.31.1-56.fc12.x86_64
                              #1 SMP Tue Sep 29 16:16:22 EDT 2009 x86_64 x86_64
Alert Count                   5
First Seen                    Mon 12 Oct 2009 12:09:44 PM CEST
Last Seen                     Tue 13 Oct 2009 10:35:58 PM CEST
Local ID                      1e36d8ae-4cf4-4d2f-b1e3-373b7e68859f
Line Numbers                  

Raw Audit Messages            

node=(removed) type=AVC msg=audit(1255466158.480:87): avc:  denied  { execmem } for  pid=13608 comm="ksudoku" scontext=unconfined_u:unconfined_r:unconfined_t:s0-s0:c0.c1023 tcontext=unconfined_u:unconfined_r:unconfined_t:s0-s0:c0.c1023 tclass=process

node=(removed) type=SYSCALL msg=audit(1255466158.480:87): arch=c000003e syscall=9 success=yes exit=230336118784 a0=35a11a4000 a1=3d000 a2=7 a3=812 items=0 ppid=1596 pid=13608 auid=500 uid=500 gid=500 euid=500 suid=500 fsuid=500 egid=500 sgid=500 fsgid=500 tty=(none) ses=1 comm="ksudoku" exe="/usr/bin/ksudoku" subj=unconfined_u:unconfined_r:unconfined_t:s0-s0:c0.c1023 key=(null)



Hash String generated from  selinux-policy-3.6.32-24.fc12,catchall_boolean,amarok,unconfined_t,unconfined_t,process,execmem
audit2allow suggests:

#============= unconfined_t ==============
allow unconfined_t self:process execmem;

Comment 1 Martin Kho 2009-10-13 20:47:15 UTC
Hi,

I've reported this denial because there seems to be two - totally - independent applications involved.ksudoku is a game and amarok a multimedia app. Is there a logical explanation for this 'relationship'?

Martin Kho

Comment 2 Daniel Walsh 2009-10-13 21:40:15 UTC
Did you previously get an AVC on amarok?  This looks like a bug in setroubleshoot?

Which app actually generated the AVC?

Comment 3 Martin Kho 2009-10-13 22:16:26 UTC
Hi,

Found the cause of my AVC's. I was trying/testing the nvidia beta propriety driver. This generated all sort of AVC's. Now I'am running nouveau again and get no errors. Sorry for the noise :-X

Martin Kho

Comment 4 Daniel Walsh 2009-10-14 12:38:14 UTC
Ok if you want to use the nvidia driver you need to set the boolean 

allow_execmem.

setsebool -P allow_execmem 1

Comment 5 Martin Kho 2009-10-14 16:42:45 UTC
Hi,

Thanks for the tip. But i like to run the open source nouveau driver :-)

Martin kho

Comment 6 Daniel Walsh 2009-10-14 16:56:28 UTC
I am not a big fan of closed source anything.  :^)


Note You need to log in before you can comment on or make changes to this bug.