This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 528822 - Honor DEFROUTE=yes|no for all connection types
Honor DEFROUTE=yes|no for all connection types
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: initscripts (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Bill Nottingham
Fedora Extras Quality Assurance
:
Depends On:
Blocks: 530209
  Show dependency treegraph
 
Reported: 2009-10-13 17:13 EDT by Dan Williams
Modified: 2014-03-16 23:20 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 530209 (view as bug list)
Environment:
Last Closed: 2009-11-08 15:16:25 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Dan Williams 2009-10-13 17:13:31 EDT
There are various problems with GATEWAYDEV, specifically that it uses device names, and there's no way to sanely modify it from a GUI if the device you'd like to set as the gateway dev isn't plugged in, you don't have persistent device names, etc.  We shouldn't be requiring the user to type in a freeform text field what device name to use here.  Plus, if the NM connection you are editing isn't locked to a device, we dont' know the device name to use, since it's a per-connection setting and not global like GATEWAYDEV is.

So, the proposal is to expand usage of DEFROUTE in the ifcfg files.  If DEFROUTE=no, then 'ifup' for that ifcfg should not touch the default route.  That's done for PPP apparently, but not for the other device types.

NM will write out DEFROUTE to the ifcfg file based on the "Only use this connection for resources on its network" checkbox, and leave GATEWAYDEV alone.  NM will still honor GATEWAYDEV when its set though.
Comment 1 Dan Williams 2009-10-13 17:13:51 EDT
See https://bugzilla.redhat.com/show_bug.cgi?id=528281 for the NM side of this.
Comment 2 Bill Nottingham 2009-10-14 16:51:09 EDT
The assumption is that no DEFROUTE implies DEFROUTE=yes, correct?
Comment 3 Dan Williams 2009-10-15 11:31:03 EDT
(In reply to comment #2)
> The assumption is that no DEFROUTE implies DEFROUTE=yes, correct?  

Yes; that should be how it currently works in initscripts, and how NetworkManager works as well.

Obviously if DEFROUTE=yes for ifcfg-eth2 but GATEWAYDEV=eth0, then eth2 still doesn't get the default route.
Comment 5 Gene Czarcinski 2009-11-08 15:16:25 EST
code is there and looks correct ... 9.02-1 is in F12

Note You need to log in before you can comment on or make changes to this bug.