Bug 528865 - Fedora 11 & 12 Installers do not detect My HDD
Fedora 11 & 12 Installers do not detect My HDD
Status: CLOSED DUPLICATE of bug 499733
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
11
x86_64 Linux
low Severity medium
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-10-14 02:25 EDT by david
Modified: 2009-10-14 04:49 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-10-14 03:09:24 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description david 2009-10-14 02:25:48 EDT
Description of problem:
I own a PCChips P55G v1.0 which is nVidia MCP73. My hard drive is in the primary sata slot and is not being recognized by anaconda on FC11 or Rawhide. While the installer cant seem to find it I am able to edit the partitions within the LiveCD env using fdisk. I tried different sata controller modes in BIOS as well "SATA,RAID,& AHCI" all failed.

How reproducible:
Every time. For me anyway.

Steps to Reproduce:
1. Own a PCChips P55G Motherboard
2. Have sata HDD
3. Try to run installer
  
Additional info:

Anaconda.log:

      21:56:01 INFO : using only installclass _Fedora
      21:56:01 INFO : anaconda called with cmdline = ['/usr/sbin/anaconda', '--liveinst', '--method=livecd:///dev/mapper/live-osimg-min', '--lang', 'en_US.UTF-8']
      21:56:01 INFO : Display mode = g
      21:56:01 INFO : Starting graphical installation...
      21:56:01 INFO : Detected 2000M of memory
      21:56:01 INFO : Swap attempt of 2000M to 4000M
      21:56:01 WARNING : step installtype does not exist
      21:56:01 WARNING : step confirminstall does not exist
      21:56:01 WARNING : step complete does not exist
      21:56:01 INFO : moving (1) to step welcome
      21:56:03 INFO : moving (1) to step keyboard
      21:56:04 INFO : moving (1) to step storageinit
      21:56:04 INFO : no /tmp/fcpconfig; not configuring zfcp
      21:56:04 DEBUG : DeviceTree.addUdevDevice: name: sda ;
      21:56:04 DEBUG : StorageDevice._setFormat: sda ; current: None ; type: None ;
      21:56:04 DEBUG : DeviceTree.handleUdevDeviceFormat: name: sda ;
      21:56:04 DEBUG : DMRaidMember.__init__: device: /dev/sda ; uuid: None ; exists: True ; label: None ;
      21:56:04 DEBUG : StorageDevice._setFormat: sda ; current: None ; type: dmraidmember ;
      21:56:04 DEBUG : DeviceTree.handleUdevDMRaidMemberFormat: type: dmraidmember ; name: sda ;
      21:56:04 DEBUG : DeviceTree.addUdevDevice: name: live-rw ;
      21:56:04 DEBUG : DeviceTree.addUdevDMDevice: name: live-rw ;
      21:56:04 DEBUG : DeviceTree.addUdevDevice: name: loop3 ;
      21:56:04 DEBUG : DeviceTree.handleUdevDeviceFormat: name: None ;
      21:56:04 DEBUG : DeviceTree.addUdevDevice: name: live-osimg-min ;
      21:56:04 DEBUG : DeviceTree.addUdevDMDevice: name: live-osimg-min ;
      21:56:04 DEBUG : DeviceTree.addUdevDevice: name: loop3 ;
      21:56:04 DEBUG : DeviceTree.handleUdevDeviceFormat: name: None ;
      21:56:04 DEBUG : StorageDevice.teardown: sda ; status: True ;
      21:56:04 DEBUG : DMRaidMember.teardown: device: /dev/sda ; status: True ; type: dmraidmember ;
      21:56:04 INFO : moving (1) to step network
      21:56:06 INFO : moving (1) to step timezone
      21:56:08 INFO : moving (1) to step accounts
      21:56:26 INFO : moving (1) to step setuptime
      17:56:27 INFO : moving (1) to step parttype

Program.log:

      Running... ['udevadm', 'trigger', '--subsystem-match=block']
      Running... ['udevadm', 'settle', '--timeout=30']
      Running... ['udevadm', 'settle', '--timeout=30']
      Running... ['udevadm', 'settle', '--timeout=10']
      Running... ['/usr/sbin/hwclock', '--hctosys', '-u']


Storage.log:

      [2009-10-12 21:55:59,681] DEBUG: registered device format class PPCPRePBoot as prepboot
      [2009-10-12 21:55:59,681] DEBUG: registered device format class SwapSpace as swap
      [2009-10-12 21:55:59,682] DEBUG: registered device format class DMRaidMember as dmraidmember
      [2009-10-12 21:55:59,682] DEBUG: registered device format class LVMPhysicalVolume as lvmpv
      [2009-10-12 21:55:59,862] DEBUG: registered device format class LUKS as luks
      [2009-10-12 21:55:59,863] DEBUG: registered device format class Ext2FS as ext2
      [2009-10-12 21:55:59,863] DEBUG: registered device format class Ext3FS as ext3
      [2009-10-12 21:55:59,863] DEBUG: registered device format class Ext4FS as ext4
      [2009-10-12 21:55:59,863] DEBUG: registered device format class FATFS as vfat
      [2009-10-12 21:55:59,863] DEBUG: registered device format class EFIFS as efi
      [2009-10-12 21:55:59,863] DEBUG: registered device format class BTRFS as btrfs
      [2009-10-12 21:55:59,864] DEBUG: registered device format class GFS2 as gfs2
      [2009-10-12 21:55:59,864] DEBUG: registered device format class JFS as jfs
      [2009-10-12 21:55:59,864] DEBUG: registered device format class XFS as xfs
      [2009-10-12 21:55:59,864] DEBUG: registered device format class HFS as hfs
      [2009-10-12 21:55:59,864] DEBUG: registered device format class AppleBootstrapFS as appleboot
      [2009-10-12 21:55:59,864] DEBUG: registered device format class HFSPlus as hfs+
      [2009-10-12 21:55:59,864] DEBUG: registered device format class NTFS as ntfs
      [2009-10-12 21:55:59,864] DEBUG: registered device format class NFS as nfs
      [2009-10-12 21:55:59,865] DEBUG: registered device format class NFSv4 as nfs4
      [2009-10-12 21:55:59,865] DEBUG: registered device format class Iso9660FS as iso9660
      [2009-10-12 21:55:59,865] DEBUG: registered device format class NoDevFS as nodev
      [2009-10-12 21:55:59,865] DEBUG: registered device format class DevPtsFS as devpts
      [2009-10-12 21:55:59,865] DEBUG: registered device format class ProcFS as proc
      [2009-10-12 21:55:59,865] DEBUG: registered device format class SysFS as sysfs
      [2009-10-12 21:55:59,865] DEBUG: registered device format class TmpFS as tmpfs
      [2009-10-12 21:55:59,866] DEBUG: registered device format class BindFS as bind
      [2009-10-12 21:55:59,866] DEBUG: registered device format class MDRaidMember as mdmember
      [2009-10-12 21:56:04,521] INFO: sr0 looks to be the live device; ignoring
      [2009-10-12 21:56:04,522] INFO: devices to scan: ['sda', 'dm-0', 'dm-1']
      [2009-10-12 21:56:04,664] DEBUG: scanning sda (/devices/pci0000:00/0000:00:0e.0/host0/target0:0:0/0:0:0:0/block/sda)...
      [2009-10-12 21:56:04,664] DEBUG: looking for device 'sda'...
      [2009-10-12 21:56:04,664] DEBUG: found None
      [2009-10-12 21:56:04,664] DEBUG: sda is part of a dmraid
      [2009-10-12 21:56:04,664] DEBUG: getFormat('None') returning DeviceFormat instance
      [2009-10-12 21:56:04,666] DEBUG: added sda (storage device) to device tree
      [2009-10-12 21:56:04,667] DEBUG: {'DKD_PARTITION_TABLE': '1', 'ID_REVISION': '3.18', 'ID_VENDOR_ENC': 'ATA\\x20\\x20\\x20\\x20\\x20', 'ID_ATA_COMPAT': 'ST380013AS_3JV4NE9T', 'ID_FS_VERSION': '1.0.00', 'ID_PATH': 'pci-0000:00:0e.0-scsi-0:0:0:0', 'ID_VENDOR': 'ATA', 'ID_SERIAL': 'SATA_ST380013AS_3JV4NE9T', 'DKD_PARTITION_TABLE_SCHEME': 'mbr', 'DEVTYPE': 'disk', 'MINOR': '0', 'ID_FS_TYPE': 'isw_raid_member', 'ID_MODEL': 'ST380013AS', 'MAJOR': '8', 'sysfs_path': '/devices/pci0000:00/0000:00:0e.0/host0/target0:0:0/0:0:0:0/block/sda', 'ID_FS_USAGE': 'raid', 'ID_TYPE': 'disk', 'ID_BUS': 'scsi', 'symlinks': ['block/8:0', 'disk/by-id/scsi-SATA_ST380013AS_3JV4NE9T', 'disk/by-id/ata-ST380013AS_3JV4NE9T', 'disk/by-path/pci-0000:00:0e.0-scsi-0:0:0:0'], 'ID_SERIAL_SHORT': '3JV4NE9T', 'name': 'sda', 'DKD_ATA_SMART_IS_AVAILABLE': '1', 'ANACBIN': '/sbin', 'ID_MODEL_ENC': 'ST380013AS\\x20\\x20\\x20\\x20\\x20\\x20', 'DKD_MEDIA_AVAILABLE': '1'}
      [2009-10-12 21:56:04,668] DEBUG: type detected on 'sda' is 'isw_raid_member'
      [2009-10-12 21:56:04,669] DEBUG: getFormat('isw_raid_member') returning DMRaidMember instance
      [2009-10-12 21:56:04,754] DEBUG: scanning live-rw (/devices/virtual/block/dm-0)...
      [2009-10-12 21:56:04,754] DEBUG: looking for device 'live-rw'...
      [2009-10-12 21:56:04,754] DEBUG: found None
      [2009-10-12 21:56:04,754] DEBUG: live-rw is a device-mapper device
      [2009-10-12 21:56:04,755] DEBUG: looking for device 'loop3'...
      [2009-10-12 21:56:04,755] DEBUG: found None
      [2009-10-12 21:56:04,756] DEBUG: ignoring loop3 (/devices/virtual/block/loop3)
      [2009-10-12 21:56:04,756] DEBUG: looking for device 'loop3'...
      [2009-10-12 21:56:04,757] DEBUG: found None
      [2009-10-12 21:56:04,757] ERROR: failure scanning device live-rw: could not add slave loop3
      [2009-10-12 21:56:04,758] DEBUG: {'ID_FS_VERSION': '1.0', 'DKD_DM_TARGET_COUNT': '1', 'DM_OPEN': '1', 'DM_MINOR': '0', 'DM_NAME': 'live-rw', 'ID_FS_LABEL_ENC': 'Fedora-11-x86_64', 'ANACBIN': '/sbin', 'DKD_DM_TARGET_TYPES': 'snapshot', 'DKD_DM_LAST_EVENT_NR': '0', 'DEVTYPE': 'disk', 'DM_SUSPENDED': 'Active', 'DKD_DM_NAME': 'live-rw', 'DKD_DM_MAJOR': '253', 'ID_FS_UUID': '26d6886e-77bf-45bc-9228-679402a079c1', 'ID_FS_UUID_ENC': '26d6886e-77bf-45bc-9228-679402a079c1', 'ID_FS_TYPE': 'ext4', 'DM_MAJOR': '253', 'DKD_DM_OPENCOUNT': '1', 'sysfs_path': '/devices/virtual/block/dm-0', 'ID_FS_LABEL': 'Fedora-11-x86_64', 'ID_FS_USAGE': 'filesystem', 'DM_READONLY': 'Writeable', 'DKD_DM_TABLE_STATE': 'LIVE', 'MINOR': '0', 'symlinks': ['block/253:0', 'disk/by-id/dm-name-live-rw', 'disk/by-uuid/26d6886e-77bf-45bc-9228-679402a079c1', 'disk/by-label/Fedora-11-x86_64'], 'DM_TABLES_LOADED': 'Live', 'MAJOR': '253', 'name': 'dm-0', 'DKD_DM_MINOR': '0', 'DKD_DM_STATE': 'ACTIVE', 'DKD_MEDIA_AVAILABLE': '1'}
      [2009-10-12 21:56:04,758] DEBUG: no type or existing type for live-rw, bailing
      [2009-10-12 21:56:04,759] DEBUG: scanning live-osimg-min (/devices/virtual/block/dm-1)...
      [2009-10-12 21:56:04,759] DEBUG: looking for device 'live-osimg-min'...
      [2009-10-12 21:56:04,759] DEBUG: found None
      [2009-10-12 21:56:04,759] DEBUG: live-osimg-min is a device-mapper device
      [2009-10-12 21:56:04,760] DEBUG: looking for device 'loop3'...
      [2009-10-12 21:56:04,760] DEBUG: found None
      [2009-10-12 21:56:04,761] DEBUG: ignoring loop3 (/devices/virtual/block/loop3)
      [2009-10-12 21:56:04,761] DEBUG: looking for device 'loop3'...
      [2009-10-12 21:56:04,761] DEBUG: found None
      [2009-10-12 21:56:04,762] ERROR: failure scanning device live-osimg-min: could not add slave loop3
      [2009-10-12 21:56:04,763] DEBUG: {'ID_FS_VERSION': '1.0', 'DKD_DM_TARGET_COUNT': '1', 'DM_OPEN': '0', 'DM_MINOR': '1', 'DM_NAME': 'live-osimg-min', 'ID_FS_LABEL_ENC': 'Fedora-11-x86_64', 'ANACBIN': '/sbin', 'DKD_DM_TARGET_TYPES': 'snapshot', 'DKD_DM_LAST_EVENT_NR': '0', 'DEVTYPE': 'disk', 'DM_SUSPENDED': 'Active', 'DKD_DM_NAME': 'live-osimg-min', 'DKD_DM_MAJOR': '253', 'ID_FS_UUID': '26d6886e-77bf-45bc-9228-679402a079c1', 'ID_FS_UUID_ENC': '26d6886e-77bf-45bc-9228-679402a079c1', 'ID_FS_TYPE': 'ext4', 'DM_MAJOR': '253', 'DKD_DM_OPENCOUNT': '0', 'sysfs_path': '/devices/virtual/block/dm-1', 'ID_FS_LABEL': 'Fedora-11-x86_64', 'ID_FS_USAGE': 'filesystem', 'DM_READONLY': 'Read-only', 'DKD_DM_TABLE_STATE': 'LIVE', 'MINOR': '1', 'symlinks': ['block/253:1', 'disk/by-id/dm-name-live-osimg-min', 'disk/by-uuid/26d6886e-77bf-45bc-9228-679402a079c1', 'disk/by-label/Fedora-11-x86_64'], 'DM_TABLES_LOADED': 'Live', 'MAJOR': '253', 'name': 'dm-1', 'DKD_DM_MINOR': '1', 'DKD_DM_STATE': 'READONLY', 'DKD_MEDIA_AVAILABLE': '1'}
      [2009-10-12 21:56:04,763] DEBUG: no type or existing type for live-osimg-min, bailing
      [2009-10-12 21:56:04,773] INFO: sr0 looks to be the live device; ignoring
      [2009-10-12 21:56:04,785] INFO: failed to unlink /etc/mdadm.conf
Comment 1 Hans de Goede 2009-10-14 03:09:24 EDT
Your disk once was part of a BIOS RAID set, and the BIOS RAID metadata has never been removed from it.

See:
https://bugzilla.redhat.com/show_bug.cgi?id=499733#c20
https://bugzilla.redhat.com/show_bug.cgi?id=499733#c22

You can use "dmraid -rE" to remove this metadata, this should be safe, better backup first !

*** This bug has been marked as a duplicate of bug 499733 ***
Comment 2 david 2009-10-14 04:49:10 EDT
Applied "dmraid -rE" worked perfectly. Thank you for the quick response.

Note You need to log in before you can comment on or make changes to this bug.