Bug 528874 - please update Devicekit-disks to master because 7 bugs were fixed
please update Devicekit-disks to master because 7 bugs were fixed
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: DeviceKit-disks (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: David Zeuthen
Fedora Extras Quality Assurance
:
Depends On:
Blocks: F12Blocker/F12FinalBlocker
  Show dependency treegraph
 
Reported: 2009-10-14 02:56 EDT by RJ
Modified: 2013-03-05 22:59 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-11-03 00:40:18 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description RJ 2009-10-14 02:56:08 EDT
Description of problem:
Seven bugs were fixed in current git master:

http://cgit.freedesktop.org/DeviceKit/DeviceKit-disks/commit/?id=7d9be0143e8d5b34364c5b7dc27cf735da84b558

https://bugs.freedesktop.org/show_bug.cgi?id=24264 – Crash on removing NULL value from hash in device_remove()
https://bugs.freedesktop.org/show_bug.cgi?id=24351 – Firewire hard drive is considered system-internal
https://bugs.freedesktop.org/show_bug.cgi?id=24343 – Unintended side-effect when calling DriveDetach()
https://bugs.freedesktop.org/show_bug.cgi?id=24129 – Please mount vfat disks with shortname=mixed
https://bugs.freedesktop.org/show_bug.cgi?id=24054 – Devickit-disks doesn't support changing ntfs label
https://bugs.freedesktop.org/show_bug.cgi?id=24053 – MMC cards aren't automounted.
https://bugs.freedesktop.org/show_bug.cgi?id=24052 – CDROM eject button is locked while CDROM is mounted (this bug is already in Fedora database https://bugzilla.redhat.com/show_bug.cgi?id=510460)

Thank you.
Comment 1 David Zeuthen 2009-10-30 13:55:26 EDT
Sure we should do a new release for F12. Marking as blocker since bug 528909 is related. Thanks.
Comment 2 Adam Williamson 2009-11-02 17:02:31 EST
david, just a heads-up that wednesday is the deadline for the rc phase, and i'm trying to get the blocker list emptied - it'd be great if you could get this in today or tomorrow. thanks!

-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 3 David Zeuthen 2009-11-02 17:35:38 EST
I was actually just working on this; tag request is here

https://fedorahosted.org/rel-eng/ticket/3025
Comment 4 Adam Williamson 2009-11-02 18:37:59 EST
excellent, will give the new build a quick test run myself and comment on the tag request.

-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 5 Adam Williamson 2009-11-02 18:54:54 EST
009 is working fine here, afaict, no errors and palimpsest works. additionally I was suffering from the CD eject button issue and this build fixes it for me, so that's a great bonus. have added feedback on the ticket.

-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 6 Adam Williamson 2009-11-03 00:40:18 EST
Tag was done; we can close this now, it will show up in 2009-11-03 Rawhide.

-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers

Note You need to log in before you can comment on or make changes to this bug.