Bug 528897 - [abrt] geoclue crash - "arguments to %s() were incorrect, assertion \"%s\" failed in file %s line %d.\nThis is normally a bug in some application using the D-Bus library.\n") at dbus-internals.c:283
Summary: [abrt] geoclue crash - "arguments to %s() were incorrect, assertion \"%s\" fa...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: geoclue
Version: 12
Hardware: x86_64
OS: Linux
low
medium
Target Milestone: ---
Assignee: Peter Robinson
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: abrt_hash:e2bdea48a408650ddedea2c34b7...
: 536810 540209 546482 551050 554170 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2009-10-14 09:17 UTC by Matěj Cepl
Modified: 2018-04-11 17:35 UTC (History)
10 users (show)

Fixed In Version: geoclue-0.11.1.1-0.11.20091026git73b6729.fc12
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2010-02-18 22:24:05 UTC


Attachments (Terms of Use)
File: backtrace (6.53 KB, text/plain)
2009-10-14 09:17 UTC, Matěj Cepl
no flags Details
backtrace of crash when surfing identi.ca sites with midori (6.12 KB, text/plain)
2009-12-05 21:45 UTC, Dominic Hopf
no flags Details

Description Matěj Cepl 2009-10-14 09:17:27 UTC
abrt detected a crash.


How to reproduce
-----
1.
2.
3.


Comment
-----
Starting Empathy

Additional information
======


Attached files
----
backtrace

cmdline
-----
/usr/libexec/geoclue-master 


component
-----
geoclue


executable
-----
/usr/libexec/geoclue-master


kernel
-----
2.6.31.1-58.fc12.x86_64


package
-----
geoclue-0.11.1.1-0.8.20090310git3a31d26.fc12


reason
-----
Process was terminated by signal 6

Comment 1 Matěj Cepl 2009-10-14 09:17:30 UTC
Created attachment 364730 [details]
File: backtrace

Comment 2 Bug Zapper 2009-11-16 13:39:26 UTC
This bug appears to have been reported against 'rawhide' during the Fedora 12 development cycle.
Changing version to '12'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping

Comment 3 Peter Robinson 2009-11-23 03:40:53 UTC
*** Bug 540209 has been marked as a duplicate of this bug. ***

Comment 4 Peter Robinson 2009-11-23 03:41:22 UTC
*** Bug 540094 has been marked as a duplicate of this bug. ***

Comment 5 André Auzi 2009-11-23 06:51:49 UTC
(In reply to comment #4)
> *** Bug 540094 has been marked as a duplicate of this bug. ***  

Hi Peter,

After a closer look to the backtraces of the two bugs I wonder if the Bug 540094 is really a duplicate of this one (Bug 528897).

Bug 540094 actually reports a SIGSEGV in the process of creating a new instance of GeoclueNetworkManager. 

I don't use NetworkManager on the desktop I was trying empathy with, could it be a possible cause of this bug?

On the other hand, Bug 528897 (and Bug 540209 as well) denotes a dbus assertion violation.

The symptoms are different enough to let me think there could be two different issues here.

Unfortunately, I'm not familiar enough with this application to be affirmative, I just wanted to stress the point and make sure that a potential issue with NetworkManager was not overlooked. 

Kind regards,
A

Comment 6 Peter Robinson 2009-12-02 04:56:53 UTC
*** Bug 542015 has been marked as a duplicate of this bug. ***

Comment 7 Peter Robinson 2009-12-02 04:59:20 UTC
> After a closer look to the backtraces of the two bugs I wonder if the Bug
> 540094 is really a duplicate of this one (Bug 528897).

Agreed, didn't look close enough.

> Bug 540094 actually reports a SIGSEGV in the process of creating a new instance
> of GeoclueNetworkManager. 
> 
> I don't use NetworkManager on the desktop I was trying empathy with, could it
> be a possible cause of this bug?

I've seen issues with various NM dependent packages if not rebuilt against the latest version.

> On the other hand, Bug 528897 (and Bug 540209 as well) denotes a dbus assertion
> violation.

Yes, seeing similar back traces from a number of packages.

> The symptoms are different enough to let me think there could be two different
> issues here.

You are correct.

Comment 8 Peter Robinson 2009-12-02 05:03:41 UTC
*** Bug 536810 has been marked as a duplicate of this bug. ***

Comment 9 Dominic Hopf 2009-12-05 21:43:27 UTC
I'm facing a similar crash everytime I surf to an identi.ca site using Midori. Will attach my backtrace for comparison, but looks the same.

Comment 10 Dominic Hopf 2009-12-05 21:45:39 UTC
Created attachment 376369 [details]
backtrace of crash when surfing identi.ca sites with midori

Comment 11 Peter Robinson 2009-12-05 21:47:54 UTC
(In reply to comment #9)
> I'm facing a similar crash everytime I surf to an identi.ca site using Midori.
> Will attach my backtrace for comparison, but looks the same.  

There's alot of crashes in the raise.c file all over the shop. I heard of rumours of something to do with dbus. I've got about 30 bugs from different packages that I maintain in my BZ queue at the moment.

Comment 12 Peter Robinson 2009-12-11 15:50:12 UTC
*** Bug 546482 has been marked as a duplicate of this bug. ***

Comment 13 Peter Robinson 2009-12-29 21:27:35 UTC
*** Bug 551050 has been marked as a duplicate of this bug. ***

Comment 14 Peter Robinson 2010-01-12 11:17:00 UTC
*** Bug 554170 has been marked as a duplicate of this bug. ***

Comment 15 Colin Walters 2010-01-18 14:34:39 UTC
I briefly looked at the dbus-glib code here and didn't see something obviously wrong there.  However it is apparently hitting an uncommon error path, which is when we fail to demarshal an argument; dbus-glib's handling of this is fairly lame, we create an "ErrorError" message.

My guess here is that something is sending an unregistered object path to geoclue.  This shouldn't be a fatal error though, something else is going wrong.

Comment 16 Fedora Update System 2010-01-29 13:04:52 UTC
geoclue-0.11.1.1-0.11.20091026git73b6729.fc12 has been submitted as an update for Fedora 12.
http://admin.fedoraproject.org/updates/geoclue-0.11.1.1-0.11.20091026git73b6729.fc12

Comment 17 Fedora Update System 2010-02-01 01:19:22 UTC
geoclue-0.11.1.1-0.11.20091026git73b6729.fc12 has been pushed to the Fedora 12 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update geoclue'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F12/FEDORA-2010-1289

Comment 18 Fedora Update System 2010-02-18 22:23:59 UTC
geoclue-0.11.1.1-0.11.20091026git73b6729.fc12 has been pushed to the Fedora 12 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.