Bug 528939 - I get a ghost effect in the vnc linux guests window and scrolling in firefox or other programs
Summary: I get a ghost effect in the vnc linux guests window and scrolling in firefox ...
Keywords:
Status: CLOSED DUPLICATE of bug 503156
Alias: None
Product: Fedora
Classification: Fedora
Component: kvm
Version: 11
Hardware: All
OS: Linux
low
medium
Target Milestone: ---
Assignee: Glauber Costa
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2009-10-14 12:39 UTC by G. Michael Carter
Modified: 2009-10-16 13:21 UTC (History)
7 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2009-10-16 13:21:14 UTC
Type: ---


Attachments (Terms of Use)
Effect when using the scroll bar. (159.14 KB, image/png)
2009-10-14 12:40 UTC, G. Michael Carter
no flags Details

Description G. Michael Carter 2009-10-14 12:39:19 UTC
Description of problem:

I have several guessed running qemu-kvm.  (Windows, Solaris, and Linux)  I use virtual-manager/vnc to connect to the machines.  (even tried a direct vnc connection to the kvm and get the same results)  If I open firefox, or other program with a scroll bar, and scroll down, I get parts of the text and images staying put.   Then if I move the mouse over the mess, it repaints those sections.  The only way for me to see the screen properly is to minimize and maximize the program.  This is only happening on my Linux guests.  The solaris and Windows guest machines are fine.

I've attached a screen shot of the effect.

Version-Release number of selected component (if applicable):

qemu.x86_64                          2:0.10.6-6.fc11             @updates       
qemu-common.x86_64                   2:0.10.6-6.fc11             @updates       
qemu-img.x86_64                      2:0.10.6-6.fc11             @updates       
qemu-kvm.x86_64                      2:0.10.6-6.fc11             @updates       
qemu-kvm-tools.x86_64                2:0.10.6-6.fc11             @updates       
qemu-system-arm.x86_64               2:0.10.6-6.fc11             @updates       
qemu-system-cris.x86_64              2:0.10.6-6.fc11             @updates       
qemu-system-m68k.x86_64              2:0.10.6-6.fc11             @updates       
qemu-system-mips.x86_64              2:0.10.6-6.fc11             @updates       
qemu-system-ppc.x86_64               2:0.10.6-6.fc11             @updates       
qemu-system-sh4.x86_64               2:0.10.6-6.fc11             @updates       
qemu-system-sparc.x86_64             2:0.10.6-6.fc11             @updates       
qemu-system-x86.x86_64               2:0.10.6-6.fc11             @updates       
qemu-user.x86_64                     2:0.10.6-6.fc11             @updates       
libvirt.x86_64                       0.7.0-999ovirt.6.fc11       @ovirt         
libvirt-cim.x86_64                   0.5.4-2.fc11                @fedora        
libvirt-client.x86_64                0.7.0-999ovirt.6.fc11       @ovirt         
libvirt-python.x86_64                0.7.0-999ovirt.6.fc11       @ovirt         
virt-manager.x86_64                  0.7.0-7.fc11                @updates       
virt-mem.x86_64                      0.3.1-6.fc11                @fedora        
virt-top.x86_64                      1.0.3-4.fc11                @fedora        
virt-viewer.x86_64                   0.0.3-6.fc11                @updates

Comment 1 G. Michael Carter 2009-10-14 12:40:38 UTC
Created attachment 364745 [details]
Effect when using the scroll bar.

As said this only happens in Linux guests.   The version showing here is Oracle Enterprise Linux 5.4   I've also had this happening on CentOS and Fedora as well.

Comment 2 G. Michael Carter 2009-10-14 12:50:41 UTC
Correction to that last text.  I just tried in Fedora 12 Alpha and it's not a problem.  It's only happening in RedHat 5 and it's clones.

Comment 3 G. Michael Carter 2009-10-14 17:59:15 UTC
Looks like this is a RedHat bug.   I upgraded the xorg-x11-drv-cirrus.i386 (1.1.0-2.fc6) with xorg-x11-drv-cirrus-1.1.0-5.fc8.i386.rpm and my problem has gone away. Tried fc9 but it uses a later version of the xorg.

Can this bug be moved to the redhat cirrus driver queue?

Comment 4 Mark McLoughlin 2009-10-16 13:21:14 UTC
Interesting that it went a way with a newer cirrus driver, but I'm pretty sure this is a bug in qemu too

*** This bug has been marked as a duplicate of bug 503156 ***


Note You need to log in before you can comment on or make changes to this bug.