Bug 528940 - rdiff-backup patch for fix using os.popen2 in python 2.6
Summary: rdiff-backup patch for fix using os.popen2 in python 2.6
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: rdiff-backup
Version: 12
Hardware: All
OS: Linux
low
medium
Target Milestone: ---
Assignee: Kevin Fenzi
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 551068 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2009-10-14 12:39 UTC by John Khvatov
Modified: 2010-03-21 03:19 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2010-03-21 03:19:47 UTC
Type: ---


Attachments (Terms of Use)
patch (1.01 KB, patch)
2009-10-14 12:42 UTC, John Khvatov
no flags Details | Diff

Description John Khvatov 2009-10-14 12:39:47 UTC
Description of problem:
rdiff-backup says:
/usr/lib/python2.6/site-packages/rdiff_backup/SetConnections.py:148: DeprecationWarning: os.popen2 is deprecated.  Use the subprocess module.
  stdin, stdout = os.popen2(remote_cmd)

I have a patch to change it. I'll try to submit it to upstream.

Scratch build with my patch:
http://koji.fedoraproject.org/koji/taskinfo?taskID=1745836

I tested it. It works.

Comment 1 John Khvatov 2009-10-14 12:42:12 UTC
Created attachment 364746 [details]
patch

Comment 2 Kevin Fenzi 2009-10-14 20:39:52 UTC
Thanks. 

Upstream is usually pretty responsive to these kinds of patches... if you could get them to apply that would be lovely.

Comment 3 Bug Zapper 2009-11-16 13:40:22 UTC
This bug appears to have been reported against 'rawhide' during the Fedora 12 development cycle.
Changing version to '12'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping

Comment 4 Kevin Fenzi 2009-12-28 20:04:58 UTC
*** Bug 551068 has been marked as a duplicate of this bug. ***

Comment 5 Kevin Fenzi 2009-12-28 20:06:57 UTC
I can carry this patch in the Fedora package, but have you tried submitting it upstream?

If not, I can submit it there as well if you like...

Comment 6 John Khvatov 2009-12-29 12:22:35 UTC
I added a comment to an existing bugreport long ago:
https://savannah.nongnu.org/bugs/?26064
But the patch is not accepted in the mainline.

Feel free to submit my patch another way.

Comment 7 Kevin Fenzi 2010-01-02 21:14:01 UTC
I commented on that savannah bug, if that doesn't work I will try the mailing list. 

The patch works fine here, BTW.

Comment 8 Kevin Fenzi 2010-03-21 03:19:47 UTC
I've commited the patch in rawhide:

http://koji.fedoraproject.org/koji/taskinfo?taskID=2065509

I don't think it's worth pushing out to stable releases for just that fix, but will push it out next time there is some reason to update stable releases. 

Thanks for the patch and your patience.


Note You need to log in before you can comment on or make changes to this bug.