Bug 52900 - wmaker.inst is broken
Summary: wmaker.inst is broken
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: WindowMaker   
(Show other bugs)
Version: 7.3
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Crutcher Dunnavant
QA Contact: David Lawrence
URL:
Whiteboard:
Keywords:
: 53093 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-08-30 18:06 UTC by Ben Levenson
Modified: 2007-04-18 16:36 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-09-08 21:19:12 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Ben Levenson 2001-08-30 18:06:49 UTC
Description of Problem:
WindowMaker will not start for first time users due to a syntax error
in wmaker.inst. copy() is broken:
<snip>
copy() {
        source=$1
        target=$2
        file=`basename $source`
        rm -f $target
        if [ "$file" = "WindowMaker" ]; then
                sed -e "s|~/GNUstep|$GSDIR|g" $source > $target
        elif [ "$file" = "WMRootMenu" ]; then
                if [ "$LOCALE" ]; then
                    if [ -f $GLOBALDIR/plmenu.${LOCALE} ]; then
                        source=$GLOBALDIR/plmenu.${LOCALE}
                    if [ -f $GLOBALDIR/plmenu.${LOCALE%_*} ]; then
                        source=$GLOBALDIR/plmenu.${LOCALE%_*}
                    if [ -f $GLOBALDIR/plmenu.${LOCALE%_*.*} ]; then
                        source=$GLOBALDIR/plmenu.${LOCALE%_*.*}
                    elif [ -f $GLOBALDIR/menu.${LOCALE} ]; then
                        source=$GLOBALDIR/menu.${LOCALE}
                    elif [ -f $GLOBALDIR/menu.${LOCALE%_*} ]; then
                        source=$GLOBALDIR/menu.${LOCALE%_*}
                    elif [ -f $GLOBALDIR/menu.${LOCALE%_*.*} ]; then
                        source=$GLOBALDIR/menu.${LOCALE%_*.*}
                    else
                        source=$GLOBALDIR/plmenu
                    fi
                else
                    source=$GLOBALDIR/plmenu
                fi
                sed -e "s:#wmdatadir#:$GLOBALDIR:g" \
                        $source > $GSDIR/Defaults/WMRootMenu
        else
                if test "x$GNUSTEP_USER_ROOT" = "x"; then
                        sed -e "s:#wmdatadir#:$GLOBALDIR:g" \
                                        $source > $target
                else
                        sed -e "s|\$HOME/GNUstep|$GSDIR|g" \
                                -e "s:#wmdatadir#:$GLOBALDIR:g" \
                                        $source > $target
                fi
        fi
}
<snip>


to fix:
    :71,73s/if/elif/
 
Version-Release number of selected component (if applicable):
WindowMaker-0.65.1-2

How Reproducible:
100%

Comment 1 Bill Nottingham 2001-09-04 00:27:44 UTC
*** Bug 53093 has been marked as a duplicate of this bug. ***

Comment 2 Crutcher Dunnavant 2001-09-04 14:22:16 UTC
you're fix is correct, and I introduced this bug.
Thanks.

Comment 3 Chris Ricker 2001-09-08 21:19:07 UTC
This is still broken in RC2 (0.65.1-2).  Is the RawHide fix before or after RC2?

Comment 4 Jeremy Katz 2001-09-09 02:26:47 UTC
After RC2 (WindowMaker-0.65.1-3)


Note You need to log in before you can comment on or make changes to this bug.