This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 529038 - repoquery: weird traceback on "can't open db"
repoquery: weird traceback on "can't open db"
Status: CLOSED DUPLICATE of bug 528233
Product: Fedora
Classification: Fedora
Component: yum-utils (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Seth Vidal
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-10-14 14:11 EDT by Bill Nottingham
Modified: 2014-03-16 23:20 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-10-14 14:16:29 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Bill Nottingham 2009-10-14 14:11:20 EDT
Description of problem:

[root@nostromo ~]# repoquery -C -qi nmap
rpmdb: Thread/process 14547/139850993047296 failed: Thread died in Berkeley DB library
error: db4 error(-30974) from dbenv->failchk: DB_RUNRECOVERY: Fatal error, run database recovery
error: cannot open Packages index using db3 -  (-30974)
error: cannot open Packages database in /var/lib/rpm
Traceback (most recent call last):
  File "/usr/bin/repoquery", line 853, in <module>
    main(sys.argv)
  File "/usr/bin/repoquery", line 758, in main
    repoq.doConfigSetup(debuglevel=initnoise, init_plugins=opts.plugins)
  File "/usr/lib/python2.6/site-packages/yum/__init__.py", line 199, in doConfigSetup
    return self.conf
  File "/usr/lib/python2.6/site-packages/yum/__init__.py", line 723, in <lambda>
    conf = property(fget=lambda self: self._getConfig(),
  File "/usr/lib/python2.6/site-packages/yum/__init__.py", line 249, in _getConfig
    startupconf = config.readStartupConfig(fn, root)
  File "/usr/lib/python2.6/site-packages/yum/config.py", line 805, in readStartupConfig
    startupconf.releasever = _getsysver(startupconf.installroot, startupconf.distroverpkg)
  File "/usr/lib/python2.6/site-packages/yum/config.py", line 916, in _getsysver
    if sys.hexversion < 0x02050000:
NameError: global name 'sys' is not defined

Seems like we should catch this error earlier. (Also, it's queriyng a repo, why should it care about the local rpm db?)

Version-Release number of selected component (if applicable):

yum-utils-1.1.23-3.fc12.noarch

How reproducible:

100%

Steps to Reproduce:
1. Screw up your db environment files
2. Run repoquery
Comment 1 seth vidal 2009-10-14 14:16:29 EDT

*** This bug has been marked as a duplicate of bug 528233 ***

Note You need to log in before you can comment on or make changes to this bug.