Bug 52907 - Rescuemode results in traceback
Summary: Rescuemode results in traceback
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: anaconda   
(Show other bugs)
Version: 7.3
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Brent Fox
QA Contact: Brock Organ
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-08-30 19:24 UTC by Trond Eivind Glomsrxd
Modified: 2007-04-18 16:36 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-08-30 19:37:18 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Trond Eivind Glomsrxd 2001-08-30 19:24:13 UTC
anaconda-7.1.95-1

After starting rescuemode (NFS), just after the "System is mounted under
the directory /mnt/sysimage" (translated back to English, may not match
100%), I get this traceback:

File "/usr/bin/anaconda", line 232, in ?
File "/usr/lib/anaconda/rescue.py", line 180, in runRescue
File "/usr/lib/anaconda/rescue.py", line 51, in makeMtab

IOError: [Errno 2] No such file or directory '/etc/mtab'.

Comment 1 Trond Eivind Glomsrxd 2001-08-30 19:26:01 UTC
On inspection, there is nothing under /mnt/sysimage...

Comment 2 Trond Eivind Glomsrxd 2001-08-30 19:37:13 UTC
And the reason is that rescuemode doesn't handle filesystem type "auto".

Comment 3 Jeremy Katz 2001-08-30 21:39:36 UTC
Because it's unsupported and will cause other things (such as, say, mkinitrd) to
 blow up as well...

Won't give a traceback anymore at least though as of CVS a minute or so ago


Note You need to log in before you can comment on or make changes to this bug.