Bug 529110 - gpm icon doesn't update to show whether cords is plugged in or not.
gpm icon doesn't update to show whether cords is plugged in or not.
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: gnome-power-manager (Show other bugs)
12
All Linux
low Severity medium
: ---
: ---
Assigned To: Richard Hughes
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-10-14 19:57 EDT by Rodd Clarkson
Modified: 2009-11-29 19:41 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-11-29 19:41:35 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Rodd Clarkson 2009-10-14 19:57:58 EDT
Description of problem:

Initially, gpm displays whehter or not the power cord is plugged in (after a reboot) but after some time (and suspend/resume cycles) the icon shows that there's no power cord plugged in even when there is.

The brightness of the screen changes when I plug the cord in and remove it, and the battery charge goes up when the cord is plugged in, but the icon shows me to be running on batteries regardless.


Version-Release number of selected component (if applicable):

gnome-power-manager-2.26.4-3.fc11.x86_64


How reproducible:

I'm not sure how to trigger this, but it happens after a while each time I restart my system.  I can't trigger the behaviour, but ongoing use will eventually result in it happening.
Comment 1 Rodd Clarkson 2009-10-15 03:29:09 EDT
Oh, I should add that sometimes the icon doesn't 'empty' either and thinks that the battery is just fine and dandy when in fact it's about to run out of power.

For example, I usually can get about 70 minutes from my battery, but after 20 minutes unplugged, the battery icon shows full, and reports 2 hours and 30 minutes of charge.

Recently it was showing full as I watched my system die as the power run out.
Comment 2 Rodd Clarkson 2009-11-29 19:41:35 EST
Seems to be working in f12

Note You need to log in before you can comment on or make changes to this bug.