Bugzilla will be upgraded to version 5.0 on a still to be determined date in the near future. The original upgrade date has been delayed.
Bug 52915 - lpr Winbond mesg overwrites application screen
lpr Winbond mesg overwrites application screen
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
7.1
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Tim Waugh
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-08-30 16:46 EDT by Need Real Name
Modified: 2007-04-18 12:36 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-12-18 17:42:50 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2001-08-30 16:46:49 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.76 [en] (X11; U; Linux 2.4.2-2 i686)

Description of problem:
After printer has been idle for a time a call to lpr causes this message to
appear on the screen, "Winbond Super-IO detection, now testing ports 3F0,
370, 250, 4E, 2E (etc.)...  SMSC Super-IO detection, now testing ports 2F0,
370, (etc.)."  These messages even overwrite any application screen which
is running.  In installing 7.1 I took the server option and let the
installer decide on all configs.
I have examined lpd, lprng, etc. and can not find the source of this
message.  Can not redirect to dev/null.
This only occurs after printer has been idle for a time.  If you print
again just after this message the message does not repeat (until the
printer has sat idle again for a while, - have not timed it).
Is this output possibly from new lprng utility? Or where? 
Message comes up whether logged in on console or other term.
Does not come up under xterm.  Does come up under command line terminal.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Don't know if you can reproduce. But, to try, set up 7.1 using server
class install.
2.After booting let printer (while switched on) stand idle for some time.
3.Print using lp or lpr and msg should come up.
	

Additional info:
Comment 1 Need Real Name 2001-08-31 13:45:09 EDT
Hi All,

   I have the same problem on two rh 7.1 servers.  I also have
two other servers without the problem.  

   The first two with the problem both use /dev/lp0 (lpt1) and 
are fresh installs of rh 7.1.  One is SMP and the other is
a single processor.  The SMP unit gets twice the Windbond 
gargage on the screen as the single.

   The third unit without the problem is a fresh install but
does not use /dev/lp0. (It spools for network printers with MIO cards.)

    The forth unit, also without the problem, uses /dev/lp0 but is 
an upgrade from Red Hat 7.0.  The only time the Windbond messages pop
up is if I deliberately restart lpd ("/etc/rc.d/init.d/lpd restart").

    I hope this helps,

--Tony
aewell@gbis.com
Comment 2 Need Real Name 2001-08-31 16:14:32 EDT
Super-Bond and SMSC mesgs are logged by /etc/syslog in /var/log/messages.
Comment 3 Need Real Name 2001-08-31 16:41:06 EDT
Hi All,

    The clutter (Super-Bond and SMSC mesgs) in question is being sent to both
/var/log/messages and /dev/console.  The problem is the echo to /dev/console.

--Tony
aewell@gbis.com
Comment 4 Michael Schwendt 2001-09-06 14:53:25 EDT
You could reproduce this if you removed/inserted the kernel parallel port driver
modules manually (using using "rmmod" and "modprove"). See output of "lsmod" for
which modules are loaded.

Also note kernel 2.4.3-12 update.
Comment 5 Tim Waugh 2001-12-19 03:51:17 EST
Use the 'dmesg' command to adjust the amount of kernel traffic that goes to 
the console.

This annoying message has been fixed in later kernels (2.4.5 onwards).

Note You need to log in before you can comment on or make changes to this bug.