Bug 529150 - Lost packets when ping between guest and host using rtl8139 nic
Lost packets when ping between guest and host using rtl8139 nic
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: kvm (Show other bugs)
5.5
All Linux
low Severity medium
: rc
: ---
Assigned To: jason wang
Virtualization Bugs
: Triaged
Depends On:
Blocks: Rhel5KvmTier3
  Show dependency treegraph
 
Reported: 2009-10-15 03:15 EDT by Amos Kong
Modified: 2015-05-24 20:05 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-01-27 01:26:31 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
ping message of guest (7.29 KB, text/plain)
2009-10-15 03:17 EDT, Amos Kong
no flags Details
ping message of host (8.43 KB, application/octet-stream)
2009-10-15 03:18 EDT, Amos Kong
no flags Details

  None (edit)
Description Amos Kong 2009-10-15 03:15:48 EDT
Description of problem:

When ping guest from host (host->guest) && ping host from guest (guest->host),
it always lost packets using rtl8139 nic on RHEL-Server-5.4
It's easy to reproduce set size of icmp as 65507 or 32767.

Version-Release number of selected component (if applicable):


[root@intel-q9400-4-1 ~]# rpm -qa |grep kvm
kmod-kvm-83-105.el5_4.9
kvm-qemu-img-83-105.el5_4.9
etherboot-zroms-kvm-5.4.4-10.el5
kvm-tools-83-105.el5_4.9
kvm-debuginfo-83-105.el5_4.9
kvm-83-105.el5_4.9



How reproducible:
100%

Steps to Reproduce:
1. Start a VM(RHEL-Server-5.4) using rtl8138 nic
2. Ping guest from host
3. Ping host from guest
  
Actual results:
Lost packets when ping guest from host
Lost packets when ping host form guest
No packet lost.

Expected results:
Success to ping guest from host
Success to ping host form guest
No packet lost.

Additional info:

command to start VM: (using switch)
[root@intel-q9400-4-1 images]# qemu-kvm -name vm1 -monitor stdio -drive file=./RHEL-Server-5.4-64.qcow2,media=disk,if=ide,cache=off,boot=on -net nic,vlan=0,macaddr=00:11:22:33:8D:02,model=rtl8139 -net tap,vlan=0,ifname=AUTOTEST_332,script=/etc/qemu-ifup-switch,downscript=no -m 512 -usbdevice tablet -rtc-td-hack -no-hpet -cpu qemu64,+sse2 -no-kvm-pit-reinjection -smp 1 -vnc :22
[root@intel-q9400-4-1 ~]# brctl show all
bridge name	bridge id		STP enabled	interfaces
switch		8000.0023ae8fce25	no		eth0
                                                        AUTOTEST_332
virbr0		8000.3a281deffec5	yes	

-----------------------------------------------------------

command to start VM: (using virtbr0)
[root@intel-q9400-4-1 images]# qemu-kvm -name vm1 -monitor stdio -drive file=./RHEL-Server-5.4-64.qcow2,media=disk,if=ide,cache=off,boot=on -net nic,vlan=0,macaddr=00:11:22:33:8D:02,model=rtl8139 -net tap,vlan=0,ifname=AUTOTEST_332,script=/etc/qemu-ifup-virbr0,downscript=no -m 512 -usbdevice tablet -rtc-td-hack -no-hpet -cpu qemu64,+sse2 -no-kvm-pit-reinjection -smp 1 -vnc :22

[root@intel-q9400-4-1 ~]# brctl show all
bridge name	bridge id		STP enabled	interfaces
switch		8000.0023ae8fce25	no		eth0
virbr0		8000.3a281deffec5	yes		AUTOTEST_332
-----------------------------------------------------------

Host --> guest

[root@intel-q9400-4-1 kvm_runtest_2]# ping -c 10 10.66.82.147 -s 65507
PING 10.66.82.147 (10.66.82.147) 65507(65535) bytes of data.
65515 bytes from 10.66.82.147: icmp_seq=1 ttl=64 time=86.9 ms
65515 bytes from 10.66.82.147: icmp_seq=2 ttl=64 time=1002 ms
65515 bytes from 10.66.82.147: icmp_seq=3 ttl=64 time=1002 ms
65515 bytes from 10.66.82.147: icmp_seq=4 ttl=64 time=1042 ms
65515 bytes from 10.66.82.147: icmp_seq=7 ttl=64 time=1002 ms
65515 bytes from 10.66.82.147: icmp_seq=8 ttl=64 time=1002 ms
65515 bytes from 10.66.82.147: icmp_seq=9 ttl=64 time=956 ms

--- 10.66.82.147 ping statistics ---
10 packets transmitted, 7 received, 30% packet loss, time 8999ms
rtt min/avg/max/mdev = 86.988/870.841/1042.910/320.850 ms, pipe 2
----------------------
Guest --> host:
[root@localhost network-scripts]# ping 10.66.82.249 -c 20 -s 32767
PING 10.66.82.249 (10.66.82.249) 32767(32795) bytes of data.
32775 bytes from 10.66.82.249: icmp_seq=1 ttl=64 time=625 ms
32775 bytes from 10.66.82.249: icmp_seq=2 ttl=64 time=109 ms
32775 bytes from 10.66.82.249: icmp_seq=3 ttl=64 time=63.4 ms
32775 bytes from 10.66.82.249: icmp_seq=4 ttl=64 time=363 ms
32775 bytes from 10.66.82.249: icmp_seq=5 ttl=64 time=735 ms
32775 bytes from 10.66.82.249: icmp_seq=6 ttl=64 time=1003 ms
32775 bytes from 10.66.82.249: icmp_seq=7 ttl=64 time=1724 ms
32775 bytes from 10.66.82.249: icmp_seq=8 ttl=64 time=1725 ms
32775 bytes from 10.66.82.249: icmp_seq=12 ttl=64 time=1002 ms
32775 bytes from 10.66.82.249: icmp_seq=13 ttl=64 time=1704 ms

--- 10.66.82.249 ping statistics ---
20 packets transmitted, 10 received, 50% packet loss, time 19041ms
rtt min/avg/max/mdev = 63.472/905.880/1725.028/611.979 ms, pipe 2
Comment 1 Amos Kong 2009-10-15 03:17:26 EDT
Created attachment 364874 [details]
ping message of guest

ping from guest to host
Comment 2 Amos Kong 2009-10-15 03:18:09 EDT
Created attachment 364875 [details]
ping message of host

ping from host to guest
Comment 8 RHEL Product and Program Management 2011-01-11 15:46:45 EST
This request was evaluated by Red Hat Product Management for
inclusion in the current release of Red Hat Enterprise Linux.
Because the affected component is not scheduled to be updated in the
current release, Red Hat is unfortunately unable to address this
request at this time. Red Hat invites you to ask your support
representative to propose this request, if appropriate and relevant,
in the next release of Red Hat Enterprise Linux.
Comment 9 RHEL Product and Program Management 2011-01-11 17:47:24 EST
This request was erroneously denied for the current release of
Red Hat Enterprise Linux.  The error has been fixed and this
request has been re-proposed for the current release.
Comment 10 Eduardo Habkost 2011-01-13 11:58:48 EST
Reassigning to mst.
Comment 12 Amos Kong 2011-01-27 01:01:44 EST
Could not reproduce this bug with latest kvm/guest.

kvm-83-219.el5  
guest: 5.5.z

Note You need to log in before you can comment on or make changes to this bug.