Bug 529215 - Fedora 11 PPC / Anaconda 11.5.0.59 - Netboot Installer fails at detecting disk.
Fedora 11 PPC / Anaconda 11.5.0.59 - Netboot Installer fails at detecting disk.
Status: CLOSED DEFERRED
Product: Fedora
Classification: Fedora
Component: parted (Show other bugs)
11
powerpc Linux
low Severity high
: ---
: ---
Assigned To: Hans de Goede
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-10-15 10:43 EDT by Seth R
Modified: 2009-12-27 11:09 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-12-16 08:14:02 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
Bug Report from Installer (31.67 KB, text/plain)
2009-10-15 10:43 EDT, Seth R
no flags Details

  None (edit)
Description Seth R 2009-10-15 10:43:24 EDT
Created attachment 364922 [details]
Bug Report from Installer 

Description of problem:

Fedora 11 PPC installer fails before disk config screen. 

Version-Release number of selected component (if applicable):

11.5.0.59 

How reproducible:

Very reproducible.

Steps to Reproduce:
1. boot netboot CD
2. boot with linux or linux64
3. configure locale and keyboard and attempt to proceed with the install
  
Actual results:

Anaconda crash.

Expected results:

Installer would proceed to choosing nfs server and directory so that install may continue.  

Additional info:
Comment 1 Chris Lumens 2009-10-15 11:01:43 EDT
anaconda 11.5.0.59 exception report
Traceback (most recent call first):
  File "/usr/lib/python2.6/site-packages/parted/disk.py", line 49, in __init__
    self.__disk = _ped.Disk(device.getPedDevice())
  File "/usr/lib/anaconda/storage/devices.py", line 716, in __init__
    self.partedDisk = parted.Disk(device=self.partedDevice)
  File "/usr/lib/anaconda/storage/devicetree.py", line 1112, in addUdevDiskDevice
    initcb=cb, initlabel=initlabel, **kwargs)
  File "/usr/lib/anaconda/storage/devicetree.py", line 1194, in addUdevDevice
    device = self.addUdevDiskDevice(info)
  File "/usr/lib/anaconda/storage/devicetree.py", line 1691, in populate
    self.addUdevDevice(dev)
  File "/usr/lib/anaconda/storage/__init__.py", line 302, in reset
    self.devicetree.populate()
  File "/usr/lib/anaconda/storage/__init__.py", line 102, in storageInitialize
    storage.reset()
  File "/usr/lib/anaconda/dispatch.py", line 205, in moveStep
    rc = stepFunc(self.anaconda)
  File "/usr/lib/anaconda/dispatch.py", line 128, in gotoNext
    self.moveStep()
  File "/usr/lib/anaconda/text.py", line 712, in run
    anaconda.dispatch.gotoNext()
  File "/usr/bin/anaconda", line 965, in <module>
    anaconda.intf.run(anaconda)
NotImplementedError: Support for reading AIX disk labels is is not implemented yet.

That message is right out of libparted, which means support's going to need to get added there first and then anaconda should just magically deal with it.  As a workaround, you can try putting a new disk label on your disk with parted before running anaconda.
Comment 2 Hans de Goede 2009-12-16 08:14:02 EST
I've talked with parted upstream about this and there are no plans to add support for AIX disk labels to parted.
Comment 3 JYundt 2009-12-26 09:24:04 EST
Out of curiosity, what does RHEL 5.4 (PPC) use for disk partitioning during install?  Because Fedora 11 (and 12) fail, but RHEL 5.4 properly recognizes disks.
Comment 4 Hans de Goede 2009-12-26 16:35:27 EST
RHEL-5.4 also uses an older version of parted, which maybe does not recognize the
AIX disklabel at all,

Could it be the disk has both a standard msdos partition tabel and an AIX one on it ?
Comment 5 JYundt 2009-12-27 11:09:49 EST
I'm not sure what version of parted RHEL 5.4 (PPC) uses, but it works like a charm.  And no, the disks don't have both an msdos label and AIX label.  I just completed an install with RHEL 5.4 (with similar storage) and everything worked fine.  

To get Fedora to install, I broke out of anaconda, used fdisk to format the disks and re-ran the installer.  Once they had an MSDOS label they worked fine.  Not sure if this'll impact how my VIO servers handle the disks though.

Note You need to log in before you can comment on or make changes to this bug.