Bug 529223 - Wireless connection freezes, routes/ips mess up
Summary: Wireless connection freezes, routes/ips mess up
Keywords:
Status: CLOSED DUPLICATE of bug 519154
Alias: None
Product: Fedora
Classification: Fedora
Component: iwl4965-firmware
Version: 11
Hardware: i386
OS: Linux
low
medium
Target Milestone: ---
Assignee: Stanislaw Gruszka
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2009-10-15 15:13 UTC by Diego De Mauro
Modified: 2009-10-19 14:16 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2009-10-19 14:16:36 UTC


Attachments (Terms of Use)

Description Diego De Mauro 2009-10-15 15:13:13 UTC
Description of problem:

After sometime connected trough wireless on a WPA2 or in a LEAP network (time varies from 2 min to 5hs) the connection looks like is frozen. Network Manager still showing connected and signal status, but user is unable to access any network service.
On my tests, if i try to ping any host, it return the a local error, like if the local ip address became the default route.
# Route command don't return the ip from the router, and freeze on first line.
# arp -a return Incomplete HWaddress from the router ip


Version-Release number of selected component (if applicable):
Last Updates applied

How reproducible:
On Lenovo T61 just install, update and connect.

Steps to Reproduce:
1. Install Fedora 11
2. Connect to a wireless network using network manager applet
3. Surf wile waiting for the bug.
  
Actual results:

Oct 15 11:33:41 L104N40 kernel: iwlagn 0000:03:00.0: Microcode SW error detected.  Restarting 0x82000000.
Oct 15 11:33:41 L104N40 kernel: Registered led device: iwl-phy0::radio
Oct 15 11:33:41 L104N40 kernel: Registered led device: iwl-phy0::assoc
Oct 15 11:33:41 L104N40 kernel: Registered led device: iwl-phy0::RX
Oct 15 11:33:41 L104N40 kernel: Registered led device: iwl-phy0::TX
Oct 15 11:34:55 L104N40 ntpd[1807]: Deleting interface #6 tun0, 9.18.198.40#123, interface stats: received=0, sent=0, dropped=0, active_time=10404 secs



Expected results:


Additional info:

Ask if any needed

Comment 1 John W. Linville 2009-10-15 15:34:55 UTC
Are those all the messages?  Are you able to 'modprobe -r iwlagn ; modprobe iwlagn' and continue working (once NM reestablishes the connection)?

Comment 2 Diego De Mauro 2009-10-15 15:49:31 UTC
Before this messages, i just got usual firewall messages, and after that just from my manually disconnect using the NM applet and reconnecting.

Will try to remove the module and reinstall it as you asked and post the results and soon as possible.

Comment 3 Diego De Mauro 2009-10-15 19:22:19 UTC
Remove and reinstall the module has the same result of manually just reconnect to the wireless network. Network Manager successfully reconnect after some seconds, and i'm able to get back to work.

Comment 4 Stanislaw Gruszka 2009-10-16 11:16:41 UTC
(In reply to comment #0)
> Oct 15 11:33:41 L104N40 kernel: iwlagn 0000:03:00.0: Microcode SW error
> detected.  Restarting 0x82000000.

I think this is duplicate of https://bugzilla.redhat.com/show_bug.cgi?id=519154

Does using swcrypto=1 module parameter works for you ?

Comment 5 Diego De Mauro 2009-10-19 12:57:40 UTC
I'm Using the parameter since last Friday, and not seeing the connection freezes anymore.

Can Fedora provide this fix upstream?

Comment 6 Stanislaw Gruszka 2009-10-19 14:16:36 UTC
This is not fix. This is workaround for firmware bug. See here:

http://bugzilla.intellinuxwireless.org/show_bug.cgi?id=2052

As have other fedora bug entry for that, I'm closing this one as duplicate.

*** This bug has been marked as a duplicate of bug 519154 ***


Note You need to log in before you can comment on or make changes to this bug.