Bug 52923 - rnc sets hardware module options incorrectly
Summary: rnc sets hardware module options incorrectly
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: redhat-config-network   
(Show other bugs)
Version: 7.3
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Phil Knirsch
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-08-30 21:28 UTC by Nalin Dahyabhai
Modified: 2015-03-05 01:09 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-08-31 12:26:27 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Nalin Dahyabhai 2001-08-30 21:28:45 UTC
Description of problem:
If you set options for network adapters, the options are saved to
modules.conf as options for the interface name ("eth0") instead of the
driver name ("eepro100"), so they have no effect.

Version-Release number of selected component (if applicable):
0.7.10-1

How reproducible:
Always

Steps to Reproduce:
1.Add an ethernet hardware device.
2.Set its IRQ (shouldn't be able to do this, since in my case it's PCI, and
the card doesn't support this as a module parameter).
3.Check /etc/modules.conf.

Actual Results:
modules.conf contains "options eth0 io=0x3500 irq=4 "

Expected Results:
modules.conf should contain "options eepro100 io=0x3500 irq=4"

Additional info:

Comment 1 Phil Knirsch 2001-08-31 12:26:22 UTC
OK, just checked. ConfModules can do it, just read and wrote the wrong variables.

Should be fixed in CVS now.

Read ya, Phil

PS: Thanks for doing all these testes, Nalin. We all really appreciate it and it
helps a lot if other people with tech skills test the tool. Developers can't see
and QA their own bugs, you know the drill :)


Note You need to log in before you can comment on or make changes to this bug.