Bugzilla (bugzilla.redhat.com) will be under maintenance for infrastructure upgrades and will not be unavailable on July 31st between 12:30 AM - 05:30 AM UTC. We appreciate your understanding and patience. You can follow status.redhat.com for details.
Bug 529231 - Please rebuild R-hdf5 for hdf5-1.8.3
Summary: Please rebuild R-hdf5 for hdf5-1.8.3
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: R-hdf5
Version: 11
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Tom "spot" Callaway
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2009-10-15 15:46 UTC by Nicola Soranzo
Modified: 2009-11-06 00:05 UTC (History)
1 user (show)

Fixed In Version: 1.6.9-4.fc11
Doc Type: Bug Fix
Doc Text:
Clone Of: 458161
Environment:
Last Closed: 2009-11-06 00:05:42 UTC
Type: ---


Attachments (Terms of Use)

Description Nicola Soranzo 2009-10-15 15:46:45 UTC
+++ This bug was initially created as a clone of Bug #458161 +++

Description of problem:
The R-hdf5 library is currently unusable, since it is built against hdf5-1.8.2 headers and the current HDF5 library is 1.8.3. HDF5 applications require that the headers and the library are at the same point release. Perhaps the R-hdf5 specfile needs to Requires: a specific release of the hdf5 package to catch this problem in future.

Version-Release number of selected component (if applicable):
R-hdf5-1.6.9-1.fc11
hdf5-1.8.3-1.fc11

How reproducible:
Always.

Steps to Reproduce:
1. Start up R.
2. Run the following:
> library('hdf5')
> hdf5save(fileout='ex.hdf5')
  
Actual results:
The HDF5 library reports the following, which crashes R:

Warning! ***HDF5 library version mismatched error***
The HDF5 header files used to compile this application do not match
the version used by the HDF5 library to which this application is linked.
Data corruption or segmentation faults may occur if the application continues.
You should recompile the application or check your shared library related
settings such as 'LD_LIBRARY_PATH'.
You can, at your own risk, disable this warning by setting the environment
variable 'HDF5_DISABLE_VERSION_CHECK' to a value of '1'.
Setting it to 2 will suppress the warning messages totally.
Headers are 1.8.2, library is 1.8.3
Bye...
Aborted


Expected results:
HDF5 file ex.hdf5 is produced.

Comment 1 Fedora Update System 2009-11-04 21:54:13 UTC
R-hdf5-1.6.9-4.fc11 has been submitted as an update for Fedora 11.
http://admin.fedoraproject.org/updates/R-hdf5-1.6.9-4.fc11

Comment 2 Fedora Update System 2009-11-06 00:05:38 UTC
R-hdf5-1.6.9-4.fc11 has been pushed to the Fedora 11 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.