Bug 529243 - QMF querying returns multiples of results.
Summary: QMF querying returns multiples of results.
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Enterprise MRG
Classification: Red Hat
Component: qpid-qmf
Version: Development
Hardware: All
OS: Linux
low
urgent
Target Milestone: 1.3
: ---
Assignee: Ted Ross
QA Contact: Jan Sarenik
URL:
Whiteboard:
Depends On: 599116 609298
Blocks:
TreeView+ depends on / blocked
 
Reported: 2009-10-15 17:23 UTC by Ian Main
Modified: 2011-08-12 16:02 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2010-10-13 13:19:16 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description Ian Main 2009-10-15 17:23:52 UTC
Description of problem:

Querying for objects in QMF results in spurious objects being returned.  For example this code:
 
      remote_pool = qmfc.object(:object_id => result.pool)
      obj_list = qmfc.objects(:object_id => result.pool)
      puts "obj list returned from object id of remote pool is #{obj_list}"
      obj_list.each do |obj|
        puts "obj entry: #{obj}"
        puts "obj entry id #{obj.object_id}"
      end

produces:

obj list returned from object id of remote pool is #<Qmf::ConsoleObject:0x7f24b95af840>#<Qmf::ConsoleObject:0x7f24b95ae710>
obj entry: #<Qmf::ConsoleObject:0x7f24b95af840>
obj entry id 0-1-1-21-4
obj entry: #<Qmf::ConsoleObject:0x7f24b95ae710>
obj entry id 0-1-1-22-4

In addition the "remote_pool" variable will be 'nil' because the object() method expects only a single return value.

We are seeing this with other query types as well which return doubles etc.

Version-Release number of selected component (if applicable):

qmf-0.5.825492-1.fc11.x86_64

How reproducible:

very.

Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:

Comment 1 Ted Ross 2009-10-15 21:38:47 UTC
Fixed upstream at svn 825672.

Comment 2 Ian Main 2009-10-15 22:26:20 UTC
Seems to be working but haven't tested extensively yet as I'm hitting other bugs. I will file new BZs :).

Comment 3 Jan Sarenik 2010-05-25 12:28:08 UTC
Ian, excuse me, what language is the original code snippet
written in and how can I use it to verify this is already
working?

Comment 4 Ian Main 2010-05-25 17:25:13 UTC
This is in ruby.

Comment 6 Jan Sarenik 2010-05-28 14:12:46 UTC
Ian, but I am unable to make the code work.
No idea where 'result' comes from. Please
give me a hint.

Comment 7 Ian Main 2010-06-07 16:30:22 UTC
Well, right now the ruby bindings are very broken, see:

https://bugzilla.redhat.com/show_bug.cgi?id=599116

So you wouldn't be able to make it work at all anyway, but take a look at 599116 as there is a ruby script in there for querying libvirt-qpid which would work to prove this bug too.


Note You need to log in before you can comment on or make changes to this bug.