Bug 529267 - Better label + icon for the installer on the live cd
Better label + icon for the installer on the live cd
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
: Reopened
Depends On:
Blocks: F12Blocker-kde
  Show dependency treegraph
 
Reported: 2009-10-15 15:45 EDT by Matthias Clasen
Modified: 2013-01-10 00:31 EST (History)
12 users (show)

See Also:
Fixed In Version: anaconda-12.42-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-11-05 17:41:50 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
install to disk icon (3.87 KB, image/png)
2009-10-28 15:46 EDT, Máirín Duffy
no flags Details
source for install to disk icon (115.17 KB, image/svg+xml)
2009-10-28 15:49 EDT, Máirín Duffy
no flags Details

  None (edit)
Description Matthias Clasen 2009-10-15 15:45:13 EDT
Wrt to the text: 

'Install to hard drive' sounds a little technical and more importantly, does not mention Fedora at all. We'd like to see it replaced by 'Install Fedora 12'. If that is not desirable because of the version dependency, 'Install Fedora' would still be much better than 'Install to hard drive'.


Wrt to the icon: 

The current icon shows a box and a cd. That can be a bit misleading, since you may run the live cd off a usb stick, and it does not show the installation target at all. We'd like to have an icon that is based on the hard disk icon that we use throughout the desktop. Jon will try to come up with a proposal.
Comment 1 Chris Lumens 2009-10-28 11:19:43 EDT
If you've got an icon, please attach it or a link to it here and I'll gladly update the desktop.in file to match.  As for this bug in general - I'm fine with updating these items, but keep in mind that it's unlikely to get fixed in F12 because of the string break and because this isn't an F12Blocker.
Comment 2 Máirín Duffy 2009-10-28 15:46:39 EDT
Created attachment 366489 [details]
install to disk icon
Comment 3 Máirín Duffy 2009-10-28 15:49:22 EDT
Created attachment 366490 [details]
source for install to disk icon
Comment 4 Máirín Duffy 2009-10-28 15:50:14 EDT
Hey Chris, the new PNG is in comment 2, me and msourada worked on it.
Comment 5 Ray Strode [halfline] 2009-10-28 16:17:33 EDT
As per discussion on IRC, adding to blocker list so it's looked at before release.

This clearly shouldn't *block* the release, but if another blocker needs to go in this one should probably go in, too, because it will make the release that much more polished with low risk.
Comment 6 Adam Williamson 2009-10-28 16:26:19 EDT
can we have a 'before' picture so we know exactly the change we're looking at here?

-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 7 Ray Strode [halfline] 2009-10-28 16:48:11 EDT
actually, moving this fedora-logos, because I don't *think* anaconda will need to be changed at all.

We just call it 

/usr/share/icons/Fedora/48x48/apps/system-software-install.png

and 

/usr/share/icons/Fedora/scalable/apps/system-software-install.svg

and everything should just work.
Comment 8 Tom "spot" Callaway 2009-10-28 19:01:43 EDT
This is built as fedora-logos-12.0.2-2.fc12, awaiting rel-eng tagging.
Comment 9 Tom "spot" Callaway 2009-10-29 08:05:05 EDT
Tagged in F-12 and built in rawhide, closing.
Comment 10 Matthias Clasen 2009-10-29 09:36:35 EDT
Grr,

I take back my words. Icons do have risk :-(

The decision to reuse the same icon name was a bad one, since now gpk-application shows up with the installer icon in the menus, which is really not what was intended here.

So, I think we need to 

a) add the new icon with a new name 

b) change the desktop file in anaconda to use the new icon
Comment 11 Tom "spot" Callaway 2009-10-29 14:12:25 EDT
fedora-logos-12.0.3-1.fc12 is tagged, the files are now named "anaconda.png" and "anaconda.svg", in the same paths.
Comment 12 Adam Williamson 2009-10-30 12:37:53 EDT
Discussed at the blocker meeting today. We can take a fix for this as long as it doesn't delay the next anaconda build. Anaconda team, just needs patching to use 'anaconda' as the icon name in the appropriate place.

-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 13 Jesse Keating 2009-10-30 13:12:36 EDT
Patch tested and submitted to anaconda list for the liveinst .desktop file.  I've also asked spot to build generic-logos with an 'anaconda' image in it too so that we don't break the de-branded case.
Comment 14 Adam Williamson 2009-10-31 00:50:22 EDT
this is in the 12.42 build:

http://koji.fedoraproject.org/koji/buildinfo?buildID=139122

tag request:

https://fedorahosted.org/rel-eng/ticket/2942

-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 15 Bill Nottingham 2009-11-02 16:24:11 EST
This should be in tomorrow's (20091103) rawhide - please retest with that.
Comment 16 Adam Williamson 2009-11-03 02:35:08 EST
the new icon is confirmed working - I just span a live image to test something else, it happened to get anaconda 12.42, and the new icon is there. Add/Remove Software has the correct icon (not the one intended for anaconda).

I note the string change hasn't been done, I guess because of the freeze, so we should probably leave the bug open. But the icon part is fixed, so dropping this from the blocker list.

-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 17 Kevin Kofler 2009-11-04 18:12:50 EST
This breaks the KDE Live image, as the new icon is only in the Fedora theme and not in anything inherited by the Fedora-KDE theme.

The icon must be moved to the common hicolor theme.
Comment 18 Kevin Kofler 2009-11-04 18:15:04 EST
This change makes the KDE Live image no longer show a liveinst icon on the desktop => blocker.
Comment 19 Rex Dieter 2009-11-04 18:24:24 EST
I just asked spot (in #fedora-devel) to add to Fedora-kde theme too.

For posterity, I'd think adding fedora-logo icons to hicolor theme would be a safer thing to do.
Comment 20 Rex Dieter 2009-11-04 18:26:43 EST
Should be fixed in
fedora-logos-12.0.3-2.fc12

http://cvs.fedoraproject.org/viewvc/rpms/fedora-logos/F-12/fedora-logos.spec?r1=1.136&r2=1.137
Comment 21 Ray Strode [halfline] 2009-11-04 19:52:35 EST
fwiw, that's my fault.  I told spot to put it in the Fedora theme originally, only to realize I should have told him hicolor 10 minutes after he pushed the build.  I didn't think it would matter in practice, so I told him not to worry about doing a new build.
Comment 22 Adam Williamson 2009-11-04 20:07:09 EST
tag request:

https://fedorahosted.org/rel-eng/ticket/3102

it does occur to me to wonder whether this is going to turn out to be broken in all the other desktop spins, too...

-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 23 Kevin Kofler 2009-11-04 20:12:35 EST
The current fix just adds the icon to Fedora-KDE too, but if spins are using other themes than Fedora or Fedora-KDE, it still won't work for them. Maybe the safest is to just move the icon to hicolor instead?
Comment 24 Ray Strode [halfline] 2009-11-04 20:15:48 EST
hicolor is definitely the "right" place for it to go.
Comment 25 Adam Williamson 2009-11-04 22:40:51 EST
<nirik> adamw: in case you didn't figure it already, Xfce uses Nodoka.
<adamw> nirik: does it inherit from Fedora?
<nirik> yes.
<adamw> whew. should be okay then, I think. still building an image to check.
 do you know what lxde does?
<nirik> not sure off hand. ;(

-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 26 Adam Williamson 2009-11-04 23:23:58 EST
I tested to confirm: an xfce build with fedora-logos-12.0.3-2.fc12 and a recent anaconda shows an icon on the desktop, and it's the right icon (the nice new one).

I'll test lxde later today or tomorrow.

-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 27 Adam Williamson 2009-11-05 17:41:50 EST
Just tested LXDE. It's fine. Closing!

-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers

Note You need to log in before you can comment on or make changes to this bug.