Bug 52927 - megaraid doesn't unload properly when no megaraid card is present
Summary: megaraid doesn't unload properly when no megaraid card is present
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: kernel   
(Show other bugs)
Version: 7.3
Hardware: i686
OS: Linux
medium
low
Target Milestone: ---
Assignee: Arjan van de Ven
QA Contact: Brock Organ
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-08-30 21:47 UTC by Need Real Name
Modified: 2007-04-18 16:36 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-09-04 16:31:18 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Need Real Name 2001-08-30 21:47:39 UTC
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 5.01; Windows NT 5.0)

Description of problem:
If you have a machine with no megaraid card in it, and you attempt to load 
the megaraid driver, the driver load will abort as it should stating there 
is no such device. However, after this process is done, /proc/devices will 
have a bogus entry in it(for 7.1 kernel, the new kernels just segmentation 
fault on a read of that file). Also, when you init 6 the box, it will 
panic at the end stating bad EIP value.

We have to load this manually for our kickstart proceedure, since qla2x00 
is autodetected prior to the aacraid or megaraid drivers, which would 
cause the OS to be installed on the external data disks, very bad esp. if 
they are shared disk.

Tried latest 2.4.7-2.18smp kernel
Happened in 7.1 as well.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Boot machine with no megaraid card
2. modprobe megariad
3. cat /proc/devices
4. init 6
	

Actual Results:  the cat /proc/devices will segmentation fault, and the 
init 6 will cause a panic at the end of the shutdown.

Additional info:

Comment 1 Arjan van de Ven 2001-09-04 16:33:57 UTC
Reproduced. Fixed.


Note You need to log in before you can comment on or make changes to this bug.