Bug 529329 - symlink icons aren't appearing on the desktop in the right place
Summary: symlink icons aren't appearing on the desktop in the right place
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: nautilus
Version: 12
Hardware: All
OS: Linux
low
medium
Target Milestone: ---
Assignee: Tomáš Bžatek
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2009-10-16 09:06 UTC by Rodd Clarkson
Modified: 2015-03-03 22:41 UTC (History)
5 users (show)

Fixed In Version: 2.22.2-3.fc12
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2009-12-01 23:59:58 UTC


Attachments (Terms of Use)

Description Rodd Clarkson 2009-10-16 09:06:07 UTC
Description of problem:

I have a bunch of symlinked folders that are on my desktop.

In f11, they are all lined up across the top of the window.
In rawhide, they appear lined up on blank desktop to the left of the screen.

If I got to f11, they appear where I put them (either in rawhide or f11), but when I return to rawhide, they have moved back to left again.  Go back to f11 (without moving them) and they appear back where they should.


Version-Release number of selected component (if applicable):

Current versions of nautilus in f11 and rawhide.  (This has been an issue for some time, but I've only just got my desktop stable enough to take the time to report this, sorry)

How reproducible:

Very.  Every time I return to rawhide, they are back on blank desktop to the left, instead of where I want them.

Comment 1 Andy Lawrence 2009-10-17 16:09:06 UTC
Same here, x64 Current Rawhide.  

Symbolic link icons/folders do not stay where they are put.  A logout/reboot will reorganize them to the left of the desktop screen.

Other local files/folders stay put!

Comment 2 Matthias Clasen 2009-10-17 18:53:59 UTC
Hmm. I believe that this was supposed to be fixed with 
https://bugzilla.gnome.org/show_bug.cgi?id=593809
in glib 2.22.1.

What version of glib2 do you have ?

Comment 3 Andy Lawrence 2009-10-17 19:19:55 UTC
glib2-2.22.2-1.fc12.x86_64

I can confirm this is not fixed.

Comment 4 Andy Lawrence 2009-10-31 15:27:38 UTC
Bug ping.  Still an issue with glib2-2.22.2-2.fc12.x86_64.

Comment 5 Tomáš Bžatek 2009-11-02 11:20:37 UTC
Confirming, placing symlink to desktop, moving the icon somewhere else and pressing F5 (refresh) would line up it back to a default position. Doesn't happen with other files or folders, just symlinks to a directory (symlinked files are fine). 

Looks like a gvfs metadata bug, happens also with clean ~/.local/share/gvfs-metadata.

Comment 6 Takehiko Abe 2009-11-06 14:34:20 UTC
I believe that the fix commited for the bug 593809:

  Always report metadata on the path, not symlink target
  http://git.gnome.org/cgit/glib/commit/?id=6f1ce483eb136159f42b7dde3aa4466ba3e874c1

forgot to handle device id. As a result, gvfs does not report correct
metadata when the symlink's target is on a different device.

Please see bug 593809:
https://bugzilla.gnome.org/show_bug.cgi?id=593809

I posted some comments there.

Comment 7 Bug Zapper 2009-11-16 13:44:42 UTC
This bug appears to have been reported against 'rawhide' during the Fedora 12 development cycle.
Changing version to '12'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping

Comment 8 Fedora Update System 2009-11-30 17:45:37 UTC
glib2-2.22.2-3.fc12 has been submitted as an update for Fedora 12.
http://admin.fedoraproject.org/updates/glib2-2.22.2-3.fc12

Comment 9 Andy Lawrence 2009-11-30 21:37:41 UTC
I can confirm this fixes the issue.  Thanks!

Comment 10 Rodd Clarkson 2009-12-01 23:59:58 UTC
Yeah, I can confirm that this is fixed too.

It turns out that you need to move the icons back where you want them and then it's all good.

I was switching between f11 and f12 and in f11 they were in the right place, in f12 they weren't, so I assumed (wrongly???) that once this was fixed, this would see the icons in the 'Right Place' in f12 without having to redo the layout.  Turns out I was wrong.

Comment 11 Fedora Update System 2009-12-02 04:49:14 UTC
glib2-2.22.2-3.fc12 has been pushed to the Fedora 12 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.