Bug 529348 - Running vm-dump-metrics on KVM guest produces Segmentation fault if metrics disk is not attached
Summary: Running vm-dump-metrics on KVM guest produces Segmentation fault if metrics d...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: vhostmd
Version: rawhide
Hardware: x86_64
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Richard W.M. Jones
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2009-10-16 09:50 UTC by Frank Danapfel
Modified: 2009-11-10 17:50 UTC (History)
1 user (show)

Fixed In Version: 0.4-0.5.gite9db007b.fc11
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2009-11-10 17:50:18 UTC
Type: ---


Attachments (Terms of Use)

Description Frank Danapfel 2009-10-16 09:50:23 UTC
Description of problem:
Installed vhostmd on a F11 x86_64 system, and vm-dump-metrics in a KVM guest runnig F11 x86_64 on the same machine.

The vhostmd is startde on the host side, however I forgot to attach the metrics disk to the guest. Trying to run vm-dump-metrics in this situation on the guest produced the erromessage that the metrics disk can not be found, but then the program dies with a Segmentation Fault.

Version-Release number of selected component (if applicable):
vhostmd-0.4-0.2.gitea2f772d.fc11.x86_64
vm-dump-metrics-0.4-0.2.gitea2f772d.fc11.x86_64

How reproducible:
always

Steps to Reproduce:
1. remove metrics disk from KVM guest
2. run vm-dump-metrics on the guest
3. 
  
Actual results:
[root@ls3055v0 ~]# vm-dump-metrics
LIBMETRICS: libmetrics_init(): Unable to read metrics disk
Segmentation fault

In /var/log/messages the following error message is recorded when this happens:
/var/log/messages:Oct 16 11:36:49 ls3055v0 kernel: vm-dump-metrics[1808]: segfault at 100 ip 00000036b3208dd1 sp 00007fffefbba670 error 4 in libpthread-2.10.1.so[36b3200000+17000]

Expected results:
It should just print an error message if the metrics disk is not attached

Additional info:
The RPMS used to install vhostmd and vm-dump-metrics were build directly on the server using rpmbuild from the latest source RPM.

SELinux is set in permissive mode.

Comment 1 Richard W.M. Jones 2009-10-16 13:01:51 UTC
Patch sent upstream.  It will eventually appear here:

http://lists.opensuse.org/vhostmd/2009-10/

Comment 2 Richard W.M. Jones 2009-10-16 16:18:31 UTC
New build which incorporates this fix:

http://koji.fedoraproject.org/koji/taskinfo?taskID=1750365

Comment 3 Fedora Update System 2009-10-16 16:20:48 UTC
vhostmd-0.4-0.5.gite9db007b.fc11 has been submitted as an update for Fedora 11.
http://admin.fedoraproject.org/updates/vhostmd-0.4-0.5.gite9db007b.fc11

Comment 4 Fedora Update System 2009-10-16 16:21:13 UTC
vhostmd-0.4-0.5.gite9db007b.fc12 has been submitted as an update for Fedora 12.
http://admin.fedoraproject.org/updates/vhostmd-0.4-0.5.gite9db007b.fc12

Comment 5 Frank Danapfel 2009-10-19 09:30:53 UTC
The problem is solved with the latest patch. Thanks for fixing this so fast.

Frank

Comment 6 Fedora Update System 2009-10-21 00:43:32 UTC
vhostmd-0.4-0.5.gite9db007b.fc11 has been pushed to the Fedora 11 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update vhostmd'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F11/FEDORA-2009-10614

Comment 7 Fedora Update System 2009-11-10 17:50:14 UTC
vhostmd-0.4-0.5.gite9db007b.fc11 has been pushed to the Fedora 11 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.