Bug 52938 - poor recovery login when bad home dir
Summary: poor recovery login when bad home dir
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Public Beta
Classification: Retired
Component: gdm   
(Show other bugs)
Version: roswell
Hardware: i686
OS: Linux
medium
low
Target Milestone: ---
Assignee: Havoc Pennington
QA Contact: Aaron Brown
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-08-31 01:04 UTC by Per Bothner
Modified: 2007-04-18 16:36 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-09-06 22:56:51 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Tar of old ~/.gnome causing wm and panel to die (11.88 KB, application/octet-stream)
2001-09-01 20:18 UTC, Per Bothner
no flags Details

Description Per Bothner 2001-08-31 01:04:12 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.3+) Gecko/20010825

Description of problem:
I try to login using the default GUI (Gnome?) login screen, but the home
directory
listed in /etc/passwd has the wrong owner.  In that case things get rather
confused.
A window pops up with no error message and just a continue button.  Nothing
else shows on the screen.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.chown your home directory to someone else
2.login using the gui screen
3.
	

Actual Results:  A window pops up with no error message and just a continue
button.  Nothing
else shows on the screen.  Hitting the continue button gets me back to the
original screen with no indication what is wrong.

Expected Results:  Some more informative error message.  Should login with
cd as /.
Even better would be a dialog about how to fix it, but that is probably
overkill.

Additional info:

This is obviously not a showstopper or a problem many people will run into.
Most who do, will figure out how to deal with it.  Still, it's the kind of
problem
that can happen whe someone installs a new disk containing a /home partition
that may have wrong uids, or they have done an install after wiping out the
root partition (this is what I did), in which case the new uids in /etc/passwd 
may not match what is on the disk.

Comment 1 David Mason 2001-08-31 01:13:27 UTC
reassigning to gdm

Comment 2 Per Bothner 2001-08-31 02:01:01 UTC
Hm.  chown'ing and chgrp'ing my home directory (chown -R bothner bothner; chgrp
-R bothner bothner) doesn't fix it.  I can now login from a console or ssh after
loging in as root.  However
I still can't login from the GUI splash screen.


Comment 3 Havoc Pennington 2001-08-31 02:36:01 UTC
our little sanity-check app should probably check this sort of thing.

Check ~/.xsession-errors and /var/log/gdm/* for reasons the login may still be
failing.

Comment 4 Per Bothner 2001-08-31 23:20:18 UTC
Your advice was good - .xsession-errors reported "exec: fvwm2: not found".  Perhaps
this should be displayed to the user.

Next problem:  I can login but the window manager and panel die.  No
decorations, no way to
move windows, no way to log out.

This turned out to be because of an old ~/.gnome directory. I don't know which
specific
file caused the problem.  I've saved the files if you think it is worth trying
to look further into it.

Comment 5 Havoc Pennington 2001-09-01 01:06:05 UTC
Why not go ahead and attach the .gnome file, it's probably a bug worth fixing.
Or put it up for ftp/http if its size makes attaching it difficult.

Comment 6 Per Bothner 2001-09-01 20:18:56 UTC
Created attachment 30555 [details]
Tar of old ~/.gnome causing wm and panel to die

Comment 7 Ed McKenzie 2001-09-06 22:56:48 UTC
along a similar vein, a gnome login dies without any kind of useful 
feedback if the user's cookies in /tmp are owned by the wrong uid or have 
the wrong permissions.

Comment 8 Havoc Pennington 2002-02-25 20:50:22 UTC
Moved upstream as:
 http://bugzilla.gnome.org/show_bug.cgi?id=72563

Closing on RH level

Comment 9 Havoc Pennington 2002-07-11 22:59:23 UTC
Now fixed upstream and in rawhide, fwiw.


Note You need to log in before you can comment on or make changes to this bug.