Bug 52941 - 'xdvi filename.tex' launches Netscape
Summary: 'xdvi filename.tex' launches Netscape
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: tetex
Version: 7.1
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Tim Waugh
QA Contact: David Lawrence
URL:
Whiteboard:
Keywords: FutureFeature
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-08-31 04:28 UTC by pdenis2
Modified: 2007-04-18 16:36 UTC (History)
0 users

(edit)
Clone Of:
(edit)
Last Closed: 2001-09-03 13:26:19 UTC


Attachments (Terms of Use)
Here is a part of the solution. But xdvi tries a browser as a last resort for MIME types it doesn't know anyway. (602 bytes, patch)
2001-09-03 13:26 UTC, Tim Waugh
no flags Details | Diff

Description pdenis2 2001-08-31 04:28:13 UTC
From Bugzilla Helper:
User-Agent: Mozilla/4.76 [en] (X11; U; Linux 2.4.7-pre3.asl i686)

Description of problem:
If you *inadvertantly* try xdvi on a file with extension'tex' it launches
Netscape.

Version-Release number of selected component (if applicable):
tetex-xdvi-1.0.7-15 tetex-1.0.7-15

How reproducible:
Always

Steps to Reproduce:
1. create a file named 'something.tex' [contents don't matter apparently,
try mv core core.tex]
2.  xdvi something.tex
3.
	

Actual Results:  msg: Could not open dvi file. Exiting. [That's OK, its not
a dvi file ]
Then Netscape opens with "couldn't find file 'something.tex'

Expected Results:  Just the error msg., please.

Additional info:

This is hilarious, but it had me questioning my sanity.  
Something in mime-types or mailcap, maybe? Same results under KDE/Gnome.

If it's an enhancement to xdvi, please un-enhance.

[I know: Doctor it hurts when I...Don't do that]

Comment 1 Tim Waugh 2001-09-03 12:45:42 UTC
It's no enhancement. :-)

Looks like a bug in the MIME handling, along with a couple of incorrect 
settings in the default texmf.cnf.


Comment 2 Tim Waugh 2001-09-03 13:26:15 UTC
Created attachment 30694 [details]
Here is a part of the solution.  But xdvi tries a browser as a last resort for MIME types it doesn't know anyway.

Comment 3 Tim Waugh 2001-09-26 13:04:17 UTC
I think this is (for some reason) intentional behaviour, judging from the code.



Note You need to log in before you can comment on or make changes to this bug.