Bug 52946 - Wrong glphys in Turkish (ISO-8859-9) Keyboard
Wrong glphys in Turkish (ISO-8859-9) Keyboard
Status: CLOSED WONTFIX
Product: Red Hat Public Beta
Classification: Retired
Component: XFree86 (Show other bugs)
roswell
i686 Linux
high Severity medium
: ---
: ---
Assigned To: Mike A. Harris
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-08-31 04:44 EDT by Ecmel Ercan
Modified: 2007-03-26 23:48 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-09-12 06:19:04 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Screen shot (67.16 KB, image/jpeg)
2001-09-12 06:15 EDT, Ecmel Ercan
no flags Details

  None (edit)
Description Ecmel Ercan 2001-08-31 04:44:13 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.2) Gecko/20010809

Description of problem:
2 of the ISO-8859-9 (Turkish) glaphys are displayed wrong when the CAPSLOCK
key is on. (Using "tr" keyboard layout in XConfig-4)

While CAPSLOCK is on, then you press (I) key and you get (I dot) instead. 
On the other hand when you press (I dot) key you get (I).


Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.Select TURKISH keyboard in the setup
2.Under X, press CAPSLOCK
3.Press (I) key.  You will get an (I dot)
4.Press (I dot) key.  You will get an (I)
	

Expected Results:  when the CAPSLOCK is on the expected behavior should be:

Pressing on (I) key should bring an (I) glphy
Pressing on (I dot) key should bring an (I dot) glphy

Additional info:

The Turkish keyboard works perfect when the capslock key is off.  However,
when the CAPSLOCK is on, simply the above mentioned two keys are get mixed.

This bug was in Redhat 7.1 official distro as well.
Comment 1 Mike A. Harris 2001-08-31 05:51:12 EDT
This bug is of a nature that requires someone who uses this keyboard
layout in Turkish to find a solution for.  We do not have anyone
who uses this layout that is knowledgeable about XFree86 keyboard
layouts.  Since this is a general XFree86 problem, the bug should
be reported upstream to XFree86 instead as it is much more likely
to be fixed faster that way.

http://www.xfree86.org/cgi-bin/bugform.cgi
Comment 2 Ecmel Ercan 2001-09-01 13:59:31 EDT
Submitted.
Comment 3 Ecmel Ercan 2001-09-12 06:15:40 EDT
Created attachment 31638 [details]
Screen shot
Comment 4 Ecmel Ercan 2001-09-12 06:18:59 EDT
I haven't got any response from XFree team and after some time of thinking I
decided to reopen this bug.

I don't see Red Hat as a distribution anymore but an operating system.  As Red
Hat has a choice for Turkish keyboard setting for X then in my opinion Red Hat
should fix this annoying bug and give Turkish users a pleasent computing experience.
Comment 5 Mike A. Harris 2001-09-18 03:40:17 EDT
As stated, the resources to fix this require someone who knows the specifics
of how to fix it.  Red Hat does not have the resources to fix every possible
bug in every possible piece of software that ships in the distribution.

The upstream maintainers are where many bugs should be fixed.  This is one
of them.  Please submit another bug upstream via an email to:

xfree86@xfree86.org, and possible also discuss this on the xpert@xfree86.org
mailing list.  It is critically important that we delegate bug fixing to
those who best can fix them so as to make the best usage of available
resources.
Comment 6 Ecmel Ercan 2001-09-19 07:53:29 EDT
Below is a workaround for this bug:

1. Edit the file /usr/lib/X11/xkb/types/basic
2. Edit the file /usr/lib/X11/xkb/types/nocancel

Find the type "ALPHABETIC" and replace the definition in both files as below:

 type "ALPHABETIC" {
        modifiers = Shift+Lock;
        map[Shift] = Level2;
        map[Lock]= Level2;
        level_name[Level1] = "Base";
        level_name[Level2] = "Caps";
    };


3. Edit ~/.bashrc file and add the following:

export _XKB_OPTIONS_ENABLE=1
export _XKB_CONSUME_LOOKUP_MODS=1



For further information also check out the following thread:

http://www.xfree86.org/pipermail/i18n/2001-June/002074.html

Note: You will notice in that thread a second problem about shift behaviour
while capslock is on.  But on roswell, after you edit those 2 mentioned files
and added enviorement variables everything works perfect.

Note You need to log in before you can comment on or make changes to this bug.