Bug 52947 - Wacom Graphire USB doesn't work
Wacom Graphire USB doesn't work
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: XFree86 (Show other bugs)
7.2
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Mike A. Harris
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-08-31 04:51 EDT by Nils Philippsen
Modified: 2007-04-18 12:36 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-01-23 03:50:26 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
/etc/X11/XF86Config-4 (3.06 KB, text/plain)
2001-08-31 06:11 EDT, Nils Philippsen
no flags Details
X log of a working configuration (11.74 KB, text/plain)
2001-09-02 02:30 EDT, Nils Philippsen
no flags Details
X log of a not working configuration (with shipped wacom_drv.o module) (11.74 KB, text/plain)
2001-09-02 02:33 EDT, Nils Philippsen
no flags Details
diff between the two logs (5.16 KB, patch)
2001-09-02 02:34 EDT, Nils Philippsen
no flags Details | Diff

  None (edit)
Description Nils Philippsen 2001-08-31 04:51:43 EDT
Description of Problem:

The Wacom Graphire USB graphic tablet doesn't work with the wacom_drv
module shipped.

Version-Release number of selected component (if applicable):

4.1.0-0.9.13

How Reproducible:

Reproducible.

Steps to Reproduce:

Connect the tablet, load the needed kernel modules (usb-stuff, input, hid,
wacom, evdev, mousedev (not sure about that one), configure it in
XF86Config-4 (see www.lepied.com/xfree86 for how to do that) as
'AlwaysCore', see nothing happen when using the stylus or tablet mouse. xev
doesn't see any events, too.

Actual Results:

Mouse pointer doesn't move.

Expected Results:

Mouse pointer moves when using one of the tablets tools, gimp distinguishes
the different tools (stylus, eraser, cursor (aka mouse)).

Additional Information:

It works like a charm with the wacom_drv module from:
http://www.lepied.com/xfree86
Comment 1 Mike A. Harris 2001-08-31 05:46:47 EDT
Please attach your X server logs and config files.  The logs should
be from after an attempt at using the USB tablet, etc..
Comment 2 Nils Philippsen 2001-08-31 06:11:20 EDT
Created attachment 30279 [details]
/etc/X11/XF86Config-4
Comment 3 Nils Philippsen 2001-08-31 11:15:38 EDT
Here are the logs, names should be self-explanatory. I'll attach the diff as
well though I don't see dramatic differences. Maybe it's really only that the
new driver (version 25) works and the old one doesn't. One thing strikes me,
though: The strange value it gives for Suppress, I'm sure I configured something
like 10 or 20 (and not some million). This looks like a printf format bug or
similar.
Comment 4 Nils Philippsen 2001-09-02 02:30:47 EDT
Created attachment 30596 [details]
X log of a working configuration
Comment 5 Nils Philippsen 2001-09-02 02:33:03 EDT
Created attachment 30597 [details]
X log of a not working configuration (with shipped wacom_drv.o module)
Comment 6 Nils Philippsen 2001-09-02 02:34:20 EDT
Created attachment 30598 [details]
diff between the two logs
Comment 7 Mike A. Harris 2001-10-04 08:14:28 EDT
Since I don't have this hardware available, and I know that I fixed
a Wacom USB bug, could you please give feedback on the existing 4.1.0-3
packages?  If it still does not work, please let me know, otherwise,
please close bug CURRENTRELEASE.

Thanks.
Comment 8 Nils Philippsen 2001-10-16 09:10:01 EDT
Still doesn't work (only came around to testing it yesterday, sorry for the delay).
Comment 9 Nils Philippsen 2001-11-19 02:50:49 EST
This still doesn't work and I think I know why:

--- 8< --- From http://people.mandrakesoft.com/~flepied/projects/wacom/: ---
1.21.2 (Fri Oct 26 10:37:58 PDT 2001)

    * added Intuos2/Cintiq 15X support in the kernel module.

alpha 25 (Sat Aug 25 19:28:16 PDT 2001)

        * added Graphire2 support in the kernel module.
        * corrected a nasty bug for the bad report of the max pressure for the
USB devices.
        * fixed a crash at startup when a tool was on the tablet (credit to
Raymond Penners).

alpha 24 (Fri Jun 22 08:08:10 2001)

        * added support for the wacom module provided with Linux 2.4.5.
        * corrected the way I store USB events to work better under high load.
        * exported description of options (to be used by xf86cfg).
        * first try to activate a filter on USB reads.
        * preliminar support for Xinerama (to be fixed latter).
--- >8 ------------------------------------------------------
See "* added support for the wacom module provided with Linux 2.4.5." for
version alpha25 of the XFree86 driver. If there are any X Errata, this really
should be included.

BTW: The version 1.21.2 in the changelog is that of the kernel module, that
could be put into the kernel package to get support for Graphire 2 tablets as well.
Comment 10 Nils Philippsen 2002-01-22 13:23:46 EST
Mike,

current XFree86 (4.2.0) still has this old wacom driver (alpha23) instead of the
(since quite a while) current version (alpha25), which works beautifully
with current XFree86 (just checked).

Would you include the new version please? Thanks.
Comment 11 Mike A. Harris 2002-01-23 03:50:08 EST
I am wondering WTF Mandrake has not submitted this updated driver
to XFree86?  They've had PLENTY of time if they cared to send it in.
What a pain to have to go and hack up XFree86 to add stuff in that
developers should have submitted already - assuming it does work.

GRRR!

Ok, I feel better now.  ;o)

I downloaded the driver, made a diff, and am applying it to 4.2.0.
This did not make the 4.1.0 errata however.  Had Mandrake sent
it to XFree86 they could have included it into the main source tree.
Comment 12 Mike A. Harris 2002-01-23 04:50:58 EST
Added to 4.2.0-2.3

Note You need to log in before you can comment on or make changes to this bug.