Bug 529667 - UltimateLyrics crash while starting Amarok with Qt 4.6
UltimateLyrics crash while starting Amarok with Qt 4.6
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: amarok (Show other bugs)
12
All Linux
low Severity medium
: ---
: ---
Assigned To: Rex Dieter
Fedora Extras Quality Assurance
: Reopened, Triaged
Depends On:
Blocks: qt46
  Show dependency treegraph
 
Reported: 2009-10-19 08:34 EDT by Jaroslav Reznik
Modified: 2010-02-25 11:56 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-02-25 11:56:52 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Backtrace (15.27 KB, application/octet-stream)
2009-10-19 08:35 EDT, Jaroslav Reznik
no flags Details
Amarok crash with qt-4.6.0-0.2.beta1 backtrace (21.75 KB, text/plain)
2009-10-19 09:10 EDT, Thomas Janssen
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
KDE Software Compilation 211079 None None None Never

  None (edit)
Description Jaroslav Reznik 2009-10-19 08:34:36 EDT
Description of problem: %summary%


Version-Release number of selected component (if applicable):
qt-4.6.0-0.2.beta1.fc12.x86_64
amarok-2.2.0-2.fc12.x86_64

How reproducible:
every start

Steps to Reproduce:
1. run amarok
2. wait for crash
  
Actual results:
Crash...

Expected results:
Amarok and working playback ;-)
Comment 1 Jaroslav Reznik 2009-10-19 08:35:11 EDT
Created attachment 365231 [details]
Backtrace
Comment 2 Thomas Janssen 2009-10-19 09:07:53 EDT
Confirmed here with F10 x86_64

qt-4.6.0-0.2.beta1.fc10.x86_64
amarok-2.2.0-2.fc10.x86_64

-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 3 Thomas Janssen 2009-10-19 09:10:14 EDT
Created attachment 365234 [details]
Amarok crash with qt-4.6.0-0.2.beta1 backtrace

Backtrace attached
Comment 4 Jaroslav Reznik 2009-10-19 10:01:46 EDT
Solved - as Myriam pointed out it was caused by Ultimate Lyrics script. I've reported it to Ultimate Lyrics author.
Comment 5 Kevin Kofler 2009-10-25 11:44:29 EDT
Please keep this open until it's actually resolved, as it's on our Qt 4.6 tracker. We'd like this to get sorted out before 4.6 gets pushed as a stable update.
Comment 7 Vladimir Brkic 2009-10-28 18:37:26 EDT
I have been install qt 4.6 beta from kde-redhat repo and Amarok is crashing on start up. The cause is probably in QtScriptBindings because "amarok -d" shows that Amarok crash while trying to load qt.core library. It seems that loading "qt.gui, "qt.uitools" and "qt.core" crashes Amarok, but "qt.xml", "qt.network" and "qt.sql" works OK. Even catching exceptions can't stop crashing. The bug can't be fixed in Ultimate Lyrics script.

script for checking QtScriptBindings:
----------------------------------------------
try{
	Importer.loadQtBinding( "qt.xml" );
	Importer.loadQtBinding( "qt.network" );
	Importer.loadQtBinding( "qt.sql" );
	Importer.loadQtBinding( "qt.gui");
	Importer.loadQtBinding( "qt.uitools");
	Importer.loadQtBinding( "qt.core" );
}catch(e){
	Amarok.alert(e);
}
----------------------------------------------

run from terminal:
>amarok -d

If bindings can be loaded, I think script would start working properly.
Comment 8 Bug Zapper 2009-11-16 08:50:39 EST
This bug appears to have been reported against 'rawhide' during the Fedora 12 development cycle.
Changing version to '12'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 9 Rex Dieter 2010-01-12 08:34:35 EST
I'm fairly certain this should be better now.

Please re-open if you have any remaining problems wrt qt-4.6 and amarok-2.2.x
Comment 10 Rex Dieter 2010-02-25 11:50:03 EST
Re-opening, tibbs saw this still failing in irc today.
Comment 11 Rex Dieter 2010-02-25 11:56:52 EST
False alarm, a too-old UltimateLyrics script was the culprit.

Note You need to log in before you can comment on or make changes to this bug.