Bug 52969 - Kickstart install will not make partitions
Kickstart install will not make partitions
Status: CLOSED RAWHIDE
Product: Red Hat Public Beta
Classification: Retired
Component: anaconda (Show other bugs)
roswell
i686 Linux
medium Severity high
: ---
: ---
Assigned To: Jeremy Katz
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-08-31 14:37 EDT by Kyle Gonzales
Modified: 2007-04-18 12:36 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-09-04 10:41:45 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Kyle Gonzales 2001-08-31 14:37:38 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.3) Gecko/20010802

Description of problem:
Using Dell Precision 420 workstation with an IDE hard drive, but has an
unused SCSI controller onboard.

Machine performed a 7.2beta network install without a problem.

Now, using a kickstart file on a bootnet floppy , system cannot make
partitions.  Here is the top portion of the file:

### Start kickstart file snippet ###

lang en_US

network --bootproto dhcp

url --url ftp://porkchop.redhat.com/mnt/test/roswell2-i386/i386

keyboard "us"

zerombr yes
clearpart --linux
part swap --size 256
part /boot --size 32
part / --grow
install

### End kickstart file snippet ###

The install runs smoothly until it goes to create the partitions.  The main
console comes up with this error:

### Begin Error Message ###

Error Partitioning:

Could not allocate requested partitions: Partitioning failed: Could not
allocate partitions.

Press OK to reboot your system.

### End Error Message ###

There are no hard drive errors in console 3 or console 4.  I could switch
to the F2 console, and create the partitions manually using fdisk without
errors.  The "clearpart" command appears to be working, as I can create
partitions on the drive, then when the system reboots anmd the kickstart is
run, the partitons are cleared from the drive.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Utilize above kickstart file via floppy
2. Boot system, and issue the "linux ks=floppy" command at the boot prompt
3. Wait for the crap to happen ;)
	

Actual Results:  The error listed in the description happened.

Expected Results:  The install should have created the partitions and
continued the install.

Additional info:

I'm listing this as high severity, as it may indicate a problem with all
kickstarts.  I will be testing this on a box without a SCSI controller, and
will let you know the results.
Comment 1 Need Real Name 2001-09-01 22:56:40 EDT
I'm seeing a similar problem with kickstarting computers with compaq smartraid
controllers (cpqarray). Installation works great, but when kickstarting - the
installer won't find the disks to place the partition on. You have to specify
--ondisk ida/c0d0 (or something like that) before the installer finds the disks.
This situation also existed in rh7.1

The problem, atleast mine, has something to do with the naming of the devices,
like /dev/ida/c0d0p1. This problem would also affect all others using such a scheme.
Comment 2 Jeremy Katz 2001-09-04 15:06:09 EDT
The first problem is because there wasn't a size specified for the partition. 
I've added a little bit more diagnostic error checking to make it more clear
what the problem is in this case.

The second problem with smartarray controllers sounds different and should work
-- could you please confirm that it doesn't work with the most recent Roswell
release and if not, open a separate bug report.

Note You need to log in before you can comment on or make changes to this bug.