Bug 529746 - Impress crashes in ilbuno_sal.so.3 + 0x37c6c on PowerPoint document import
Summary: Impress crashes in ilbuno_sal.so.3 + 0x37c6c on PowerPoint document import
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: openoffice.org
Version: 11
Hardware: All
OS: Linux
low
medium
Target Milestone: ---
Assignee: Caolan McNamara
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2009-10-19 19:39 UTC by Pawel Salek
Modified: 2009-11-18 14:10 UTC (History)
2 users (show)

Fixed In Version: 3.1.1-19.8.fc11
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2009-11-18 14:10:09 UTC
Type: ---


Attachments (Terms of Use)
The pps file that triggers the crash. (1.75 MB, application/vnd.ms-powerpoint)
2009-10-20 17:15 UTC, Pawel Salek
no flags Details


Links
System ID Private Priority Status Summary Last Updated
OpenOffice.org 106130 0 None None None Never

Description Pawel Salek 2009-10-19 19:39:34 UTC
Description of problem:
(I)    x.org loaded video driver of...
(II) Loading /usr/lib64/xorg/modules/drivers//intel_drv.so
(II) Loading /usr/lib64/xorg/modules/drivers//vesa_drv.so
(II) Loading /usr/lib64/xorg/modules/drivers//fbdev_drv.so
(II) Unloading /usr/lib64/xorg/modules/drivers//vesa_drv.so
(II) Unloading /usr/lib64/xorg/modules/drivers//fbdev_drv.so
(==) Depth 24 pixmap format is 32 bpp
(III)  Desktop is: GNOME
(IV)   openoffice.org-kde version is: package openoffice.org-kde is not installed
(V)    libgcj version is: libgcj-4.4.1-2.fc11-x86_64
(VI)   kernel is: Linux 2.6.30.8-64.fc11.x86_64 #1 SMP Fri Sep 25 04:43:32 EDT 2009 x86_64 x86_64 x86_64
(VII)  OpenOffice.org core rpm version is: openoffice.org-core-3.1.1-19.2.fc11-x86_64
(VIII) accessibility is: false
(IX)   gtk theme is: Nodoka
(X)    icon theme is: Fedora
(XI)   metacity theme is: Nodoka
(XII)  fedora release is: Fedora release 11 (Leonidas)
(XIII) LANG is: en_US.UTF-8
...start free space details ...
Filesystem           1K-blocks      Used Available Use% Mounted on
/dev/mapper/VolGroup00-LogVol00
                      72635696  65994836   2951184  96% /
/dev/mapper/VolGroup00-LogVol00
                      72635696  65994836   2951184  96% /
...end free space details ...
...start (default) java details ...
java version "1.6.0_0"
OpenJDK Runtime Environment (IcedTea6 1.6) (fedora-29.b16.fc11-x86_64)
OpenJDK 64-Bit Server VM (build 14.0-b16, mixed mode)
...end (default) java details ...
...start sestatus details ...
SELinux status:                 enabled
SELinuxfs mount:                /selinux
Current mode:                   enforcing
Mode from config file:          enforcing
Policy version:                 24
Policy from config file:        targeted
...end sestatus details ...
...start stackreport details ...
0x7f090091cc6c: 0x1eb048: /usr/lib64/openoffice.org3/program/../basis-link/ure-link/lib/libuno_sal.so.3 + 0x37c6c
0x7f090091d78e: 0x1eb048: /usr/lib64/openoffice.org3/program/../basis-link/ure-link/lib/libuno_sal.so.3 + 0x3878e
0x3565033370: 0x167b40: /lib64/libc.so.6 + 0x33370
0x7f08ec038610: ????????
...end stackreport details ...
...start sample ldd details ...
	linux-vdso.so.1 =>  (0x00007fff243ff000)
	libgtk-x11-2.0.so.0 => /usr/lib64/libgtk-x11-2.0.so.0 (0x00007f944ef6e000)
	libgdk-x11-2.0.so.0 => /usr/lib64/libgdk-x11-2.0.so.0 (0x00007f944ecc3000)
	libatk-1.0.so.0 => /usr/lib64/libatk-1.0.so.0 (0x00007f944eaa4000)
	libgio-2.0.so.0 => /lib64/libgio-2.0.so.0 (0x00007f944e82c000)
	libpangoft2-1.0.so.0 => /usr/lib64/libpangoft2-1.0.so.0 (0x00007f944e5fe000)
	libgdk_pixbuf-2.0.so.0 => /usr/lib64/libgdk_pixbuf-2.0.so.0 (0x00007f944e3e0000)
	libpangocairo-1.0.so.0 => /usr/lib64/libpangocairo-1.0.so.0 (0x00007f944e1d5000)
	libcairo.so.2 => /usr/lib64/libcairo.so.2 (0x00007f944df5e000)
	libpango-1.0.so.0 => /usr/lib64/libpango-1.0.so.0 (0x00007f944dd15000)
	libfreetype.so.6 => /usr/lib64/libfreetype.so.6 (0x00007f944da7c000)
	libfontconfig.so.1 => /usr/lib64/libfontconfig.so.1 (0x00007f944d847000)
	libgmodule-2.0.so.0 => /lib64/libgmodule-2.0.so.0 (0x00007f944d644000)
	libgthread-2.0.so.0 => /lib64/libgthread-2.0.so.0 (0x00007f944d440000)
	librt.so.1 => /lib64/librt.so.1 (0x00007f944d237000)
	libdbus-glib-1.so.2 => /usr/lib64/libdbus-glib-1.so.2 (0x00007f944d016000)
	libdbus-1.so.3 => /lib64/libdbus-1.so.3 (0x00007f944cdd8000)
	libgobject-2.0.so.0 => /lib64/libgobject-2.0.so.0 (0x00007f944cb94000)
	libglib-2.0.so.0 => /lib64/libglib-2.0.so.0 (0x00007f944c8b6000)
	libvclplug_genlx.so => /usr/lib64/openoffice.org/basis3.1/program/libvclplug_genlx.so (0x00007f944c620000)
	libvcllx.so => /usr/lib64/openoffice.org/basis3.1/program/libvcllx.so (0x00007f944c031000)
	libpsplx.so => /usr/lib64/openoffice.org/basis3.1/program/libpsplx.so (0x00007f944bd40000)
	libsotlx.so => /usr/lib64/openoffice.org/basis3.1/program/libsotlx.so (0x00007f944badb000)
	libutllx.so => /usr/lib64/openoffice.org/basis3.1/program/libutllx.so (0x00007f944b83c000)
	libtllx.so => /usr/lib64/openoffice.org/basis3.1/program/libtllx.so (0x00007f944b590000)
	libcomphelp4gcc3.so => /usr/lib64/openoffice.org/basis3.1/program/libcomphelp4gcc3.so (0x00007f944b230000)
	libucbhelper4gcc3.so => /usr/lib64/openoffice.org/basis3.1/program/libucbhelper4gcc3.so (0x00007f944afae000)
	libuno_cppuhelpergcc3.so.3 => /usr/lib64/openoffice.org/basis3.1/program/../ure-link/lib/libuno_cppuhelpergcc3.so.3 (0x00007f944ad07000)
	libuno_cppu.so.3 => /usr/lib64/openoffice.org/basis3.1/program/../ure-link/lib/libuno_cppu.so.3 (0x00007f944aadb000)
	libvos3gcc3.so => /usr/lib64/openoffice.org/basis3.1/program/libvos3gcc3.so (0x00007f944a8b4000)
	libuno_sal.so.3 => /usr/lib64/openoffice.org/basis3.1/program/../ure-link/lib/libuno_sal.so.3 (0x00007f944a4be000)
	libXrandr.so.2 => /usr/lib64/libXrandr.so.2 (0x00007f944a2b6000)
	libX11.so.6 => /usr/lib64/libX11.so.6 (0x00007f9449f7c000)
	libXext.so.6 => /usr/lib64/libXext.so.6 (0x00007f9449d6a000)
	libdl.so.2 => /lib64/libdl.so.2 (0x00007f9449b66000)
	libpthread.so.0 => /lib64/libpthread.so.0 (0x00007f9449949000)
	libstdc++.so.6 => /usr/lib64/libstdc++.so.6 (0x00007f944963f000)
	libm.so.6 => /lib64/libm.so.6 (0x00007f94493bb000)
	libgcc_s.so.1 => /lib64/libgcc_s.so.1 (0x00007f94491a0000)
	libc.so.6 => /lib64/libc.so.6 (0x00007f9448e32000)
	libXfixes.so.3 => /usr/lib64/libXfixes.so.3 (0x00007f9448c2d000)
	libXrender.so.1 => /usr/lib64/libXrender.so.1 (0x00007f9448a23000)
	libXinerama.so.1 => /usr/lib64/libXinerama.so.1 (0x00007f9448821000)
	libXi.so.6 => /usr/lib64/libXi.so.6 (0x00007f9448617000)
	libXcursor.so.1 => /usr/lib64/libXcursor.so.1 (0x00007f944840c000)
	libXcomposite.so.1 => /usr/lib64/libXcomposite.so.1 (0x00007f944820a000)
	libXdamage.so.1 => /usr/lib64/libXdamage.so.1 (0x00007f9448008000)
	libselinux.so.1 => /lib64/libselinux.so.1 (0x00007f9447de9000)
	libpng12.so.0 => /usr/lib64/libpng12.so.0 (0x00007f9447bc4000)
	libpixman-1.so.0 => /usr/lib64/libpixman-1.so.0 (0x00007f944797e000)
	libz.so.1 => /lib64/libz.so.1 (0x00007f9447769000)
	libexpat.so.1 => /lib64/libexpat.so.1 (0x00007f9447541000)
	/lib64/ld-linux-x86-64.so.2 (0x0000003564c00000)
	libcap.so.2 => /lib64/libcap.so.2 (0x00007f944733c000)
	libi18npaperlx.so => /usr/lib64/openoffice.org/basis3.1/program/libi18npaperlx.so (0x00007f9447136000)
	libbasegfxlx.so => /usr/lib64/openoffice.org/basis3.1/program/libbasegfxlx.so (0x00007f9446e90000)
	libSM.so.6 => /usr/lib64/libSM.so.6 (0x00007f9446c88000)
	libICE.so.6 => /usr/lib64/libICE.so.6 (0x00007f9446a6c000)
	libi18nisolang1gcc3.so => /usr/lib64/openoffice.org/basis3.1/program/libi18nisolang1gcc3.so (0x00007f9446865000)
	libi18nutilgcc3.so => /usr/lib64/openoffice.org/basis3.1/program/libi18nutilgcc3.so (0x00007f9446652000)
	libicuuc.so.40 => /usr/lib64/libicuuc.so.40 (0x00007f944630c000)
	libicudata.so.40 => /usr/lib64/libicudata.so.40 (0x00007f94453c7000)
	libicule.so.40 => /usr/lib64/libicule.so.40 (0x00007f9445192000)
	libjvmaccessgcc3.so.3 => /usr/lib64/openoffice.org/basis3.1/program/../ure-link/lib/libjvmaccessgcc3.so.3 (0x00007f9444f8a000)
	libuno_salhelpergcc3.so.3 => /usr/lib64/openoffice.org/basis3.1/program/../ure-link/lib/libuno_salhelpergcc3.so.3 (0x00007f9444d86000)
	libcrypt.so.1 => /lib64/libcrypt.so.1 (0x00007f9444b4e000)
	libxcb.so.1 => /usr/lib64/libxcb.so.1 (0x00007f9444933000)
	libXau.so.6 => /usr/lib64/libXau.so.6 (0x00007f9444730000)
	libattr.so.1 => /lib64/libattr.so.1 (0x00007f944452c000)
	libuuid.so.1 => /lib64/libuuid.so.1 (0x00007f9444327000)
	libfreebl3.so => /lib64/libfreebl3.so (0x00007f94440c9000)
...end sample ldd details ...


Version-Release number of selected component (if applicable):


How reproducible:
Reproducible always - a large testing PowerPoint file can be attached on request.

Comment 1 David Tardon 2009-10-20 06:21:14 UTC
dtardon->pawsa: Could you attach the mentioned file? The stack trace seems to be corrupted, so we can infer nothing from it.

Comment 2 Pawel Salek 2009-10-20 17:15:22 UTC
Created attachment 365388 [details]
The pps file that triggers the crash.

Please find the file attached. It appears it does not trigger the crash every time. In particular, open office does not crash if I use the menu (File/Open) to open the file. It does not crash when executing "ooffice file.pps". It crashes every time when executing "ooimpress file.pps".

Comment 3 Caolan McNamara 2009-10-20 18:54:45 UTC
confirmed

Comment 4 Caolan McNamara 2009-10-21 09:05:12 UTC
Fix checked in and submitted upstream. Fix will be in >= 3.1.1-19.4 for F-11 for the next update

Comment 5 Fedora Update System 2009-10-29 08:46:58 UTC
openoffice.org-3.1.1-19.5.fc11 has been submitted as an update for Fedora 11.
http://admin.fedoraproject.org/updates/openoffice.org-3.1.1-19.5.fc11

Comment 6 Fedora Update System 2009-11-04 12:20:31 UTC
openoffice.org-3.1.1-19.5.fc11 has been pushed to the Fedora 11 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update openoffice.org'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F11/FEDORA-2009-10957

Comment 7 Fedora Update System 2009-11-07 12:59:19 UTC
openoffice.org-3.1.1-19.7.fc11 has been submitted as an update for Fedora 11.
http://admin.fedoraproject.org/updates/openoffice.org-3.1.1-19.7.fc11

Comment 8 Fedora Update System 2009-11-10 17:57:34 UTC
openoffice.org-3.1.1-19.7.fc11 has been pushed to the Fedora 11 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update openoffice.org'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F11/FEDORA-2009-11295

Comment 9 Fedora Update System 2009-11-17 11:11:04 UTC
openoffice.org-3.1.1-19.8.fc11 has been submitted as an update for Fedora 11.
http://admin.fedoraproject.org/updates/openoffice.org-3.1.1-19.8.fc11

Comment 10 Fedora Update System 2009-11-18 14:09:40 UTC
openoffice.org-3.1.1-19.8.fc11 has been pushed to the Fedora 11 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.