Bug 52977 - up2date authentication appears to time out after 1 hour
up2date authentication appears to time out after 1 hour
Status: CLOSED CURRENTRELEASE
Product: Red Hat Public Beta
Classification: Retired
Component: up2date (Show other bugs)
roswell
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Adrian Likins
Jay Turner
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-08-31 16:47 EDT by Jay Berkenbilt
Modified: 2015-01-07 18:51 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-09-04 19:50:18 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
up2date configuration file (2.42 KB, text/plain)
2001-08-31 16:50 EDT, Jay Berkenbilt
no flags Details

  None (edit)
Description Jay Berkenbilt 2001-08-31 16:47:48 EDT
Description of Problem:

Perhaps I overstated a bit in the Summary.... I am running Roswell 2
installed from scratch using the 8/16 ISO images.  At 15:40 EDT, I started
up2date.  At 16:40, up2date failed during a download of sendmail saying
that authentication was required.  I restarted up2date and it picked up
where it left off without incident.

Version-Release number of selected component (if applicable):

up2date-2.6.0-7.x.29

How Reproducible:

I'm not likely to have an opportunity to attempt to reproduce this as my
download got significantly past the half-way mark before failing.

Steps to Reproduce:
1. start up2date
2. let it run for an hour
3. hope it fails :-)

Actual Results:

as described above: up2date failed stating that authentication was required
after one hour

Expected Results:

It should have gotten all the way through.

Additional Information:

Obviously the one-hour part of this is circumstantial.  I can tell from the
timestamps in history that exactly an hour elapsed before it failed.

I am attaching my /etc/sysconfig/run/up2date file for completeness though I
doubt it is relevant.  I am running from soup.in.ql.org.  I am not posting
my systemid file for privacy reasons, but let me know if you need anything
from it.
Comment 1 Jay Berkenbilt 2001-08-31 16:50:57 EDT
Created attachment 30397 [details]
up2date configuration file
Comment 2 Adrian Likins 2001-09-04 19:50:14 EDT
This should be fixed in the next version of the client.

It now catches this exception, and relogins...
Comment 3 Jay Berkenbilt 2002-04-17 10:19:36 EDT
I was just going through all the bugs I've reported that aren't "closed" or
"resolved" and noticed this one from the distant past which has long since been
fixed.  As the poster, I've taken the liberty of closing it.  Hope that's okay.

Note You need to log in before you can comment on or make changes to this bug.