Bug 52979 - imake core dumps while trying to write temporary file into /tmp/imakeu5KQmJ
imake core dumps while trying to write temporary file into /tmp/imakeu5KQmJ
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: XFree86 (Show other bugs)
7.1
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Mike A. Harris
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-08-31 17:26 EDT by Need Real Name
Modified: 2007-04-18 12:36 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-09-17 14:05:55 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2001-08-31 17:26:29 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.3) Gecko/20010801

Description of problem:
imake crashes as follows:
 aimake
Creating linux.x86 makefiles...
sh: /tmp/imakeu5KQmJ: Permission denied
Abort (core dumped)

where aimake is an internal script which calls imake with some parameters.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.run imake
2.
3.
	

Actual Results:  core dump

Expected Results:  It should have generated a makefile

Additional info:

Here's various version info:

 cat /etc/redhat-release 
Red Hat Linux release 7.1 (Seawolf)


uname -a
Linux sjlin1 2.4.2-2smp #1 SMP Sun Apr 8 20:21:34 EDT 2001 i686 unknown

 rpm -qf /usr/X11R6/bin/imake
XFree86-devel-4.0.3-5


rpm -qif  /usr/X11R6/bin/imake
Name        : XFree86-devel                Relocations: (not relocateable)
Version     : 4.0.3                             Vendor: Red Hat, Inc.
Release     : 5                             Build Date: Fri 30 Mar 2001
06:53:34 PM PST
Install date: Thu 26 Jul 2001 05:42:47 AM PDT      Build Host:
porky.devel.redhat.com
Group       : Development/Libraries         Source RPM: XFree86-4.0.3-5.src.rpm
Size        : 9566066                          License: XFree86
Packager    : Red Hat, Inc. <http://bugzilla.redhat.com/bugzilla>
Summary     : X11R6 static libraries, headers and programming man pages.
Description :
XFree86-devel includes the libraries, header files and documentation
you'll need to develop programs which run as X clients. XFree86-devel
includes the base Xlib library as well as the Xt and Xaw widget sets.

Install XFree86-devel if you are going to develop programs which
will run as X clients.
Comment 1 Mike A. Harris 2001-09-01 07:18:15 EDT
Imake works fine for me.  Not sure what the problem is you're having,
but it is not reproduceable, and this is the first bug report filed
on it since 7.1 was released.
Comment 2 Need Real Name 2001-09-04 12:57:16 EDT
I can send a core dump file if that would be helpful to determine what's causing
the problem?
Comment 3 Need Real Name 2001-09-05 16:59:29 EDT
Here's the coredump.



(gdb) run  -v -R -DLinux -DXXXXX_linux -DXXXXX_OSTYPE=linux -DXXXXX_x86
-DXXXXX_PLAT=x86 -DXXXXX_linux_x86 -DOS_INCLUDE_FILE_NAME="<local-linux.cf>"
-DPLAT_INCLUDE_FILE_NAME="<local-x86.cf>" -DXxxxxMake=/xxxxx/tools/bin/amake
-DXxxxxImake=/xxxxx/tools/bin/aimake -T/vobs/dt/config/Imake.tmpl
-I/vobs/dt/config -s Makefile.linux.x86.9847
Starting program: /usr/X11R6/bin/imake -v -R -DLinux -DXXXXX_linux
-DXXXXX_OSTYPE=linux -DXXXXX_x86 -DXXXXX_PLAT=x86 -DXXXXX_linux_x86
-DOS_INCLUDE_FILE_NAME="<local-linux.cf>"
-DPLAT_INCLUDE_FILE_NAME="<local-x86.cf>" -DXxxxxMake=/xxxxx/tools/bin/amake
-DXxxxxImake=/xxxxx/tools/bin/aimake -T/vobs/dt/config/Imake.tmpl
-I/vobs/dt/config -s Makefile.linux.x86.9847
sh: /tmp/imakeChRXDW: Permission denied

Program received signal SIGABRT, Aborted.
0x4004e801 in __kill () from /lib/i686/libc.so.6
(gdb) where
#0  0x4004e801 in __kill () from /lib/i686/libc.so.6
#1  0x4004e5da in raise (sig=6) at ../sysdeps/posix/raise.c:27
#2  0x4004fd82 in abort () at ../sysdeps/generic/abort.c:88
#3  0x08049ee4 in strcpy () at ../sysdeps/generic/strcpy.c:31
#4  0x0804a249 in strcpy () at ../sysdeps/generic/strcpy.c:31
#5  0x0804a2e4 in strcpy () at ../sysdeps/generic/strcpy.c:31
#6  0x08048fe1 in strcpy () at ../sysdeps/generic/strcpy.c:31
#7  0x4003d177 in __libc_start_main (main=0x8048e60 <strcpy+276>, argc=17, 
    ubp_av=0xbffff5dc, init=0x8048a34, fini=0x804acbc <strcpy+8048>, 
    rtld_fini=0x4000e184 <_dl_fini>, stack_end=0xbffff5cc)
    at ../sysdeps/generic/libc-start.c:1
Comment 4 Need Real Name 2001-09-17 14:05:51 EDT
The bug can be reclosed.  Turns out it was due to a bug in the patch level
of Clearcase I was using.  Installing a newer patch fixed the problem.

It was caused by clearcase not allowing permissions (+x) to be changed on 
one of the intermediate files built by imake.

Note You need to log in before you can comment on or make changes to this bug.