Bug 529794 - cannot modify firewall using 'setup'
cannot modify firewall using 'setup'
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: setuptool (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Michal Hlavinka
Fedora Extras Quality Assurance
:
Depends On:
Blocks: F12Blocker/F12FinalBlocker
  Show dependency treegraph
 
Reported: 2009-10-20 00:17 EDT by John Poelstra
Modified: 2013-01-10 00:32 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-10-21 18:58:49 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description John Poelstra 2009-10-20 00:17:29 EDT
Description of problem:
From console cannot access firewall menu.  It appears to flash to an error screen and then back.  This is an obvious regression.

Version-Release number of selected component (if applicable):
setuptool-1.19.6-1.fc12.i686

How reproducible:
100%

Steps to Reproduce:
1. # setup
2. select and attempt to modify the firewall
3.
Comment 1 Michal Hlavinka 2009-10-20 06:35:10 EDT
thanks for reporting

Confirmed, firewall settings does not work in rawhide, but works in F-11

This was caused by change in system-config-firewall. In F-11 executing lokkit without arguments brings up -tui configuration, but it doesn't do this in rawhide, where system-config-firewall-tui must be used.

I'll fix this, just a sec... :)
Comment 2 Michal Hlavinka 2009-10-20 11:19:48 EDT
status update: Git became quite messy with commits adding back translations for removed entries. I need to find some answers first. If it seems it needs more time, I'll add patch to fedora and update repository later.
Comment 3 Michal Hlavinka 2009-10-20 14:07:02 EDT
when this bug is blocking F12Block tracking bug, does it need also rel-eng ticket for dist-f12 tag?
Comment 4 Fedora Update System 2009-10-20 14:10:26 EDT
setuptool-1.19.9-1.fc12 has been submitted as an update for Fedora 12.
http://admin.fedoraproject.org/updates/setuptool-1.19.9-1.fc12
Comment 5 John Poelstra 2009-10-20 17:26:12 EDT
All changes from here until the end need a tag to get in.
Comment 6 Jesse Keating 2009-10-21 18:58:49 EDT
Tagged for the release.

Note You need to log in before you can comment on or make changes to this bug.